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Course Practice Environment: Security Credentials 

For OS usernames and passwords, see the following: 

 If you are attending a classroom-based or live virtual class, ask your instructor or 

LVC producer for OS credential information. 

 If you are using a self-study format, refer to the communication that you received 

from Oracle University for this course.  

 

For product-specific credentials used in this course, see the following table:  

 

Product-Specific Credentials 

Product/Application Username Password 

Workspace Administrator User apex_admin Initial login: apex 

Changed To: welcome 

(will be using this all 

through the course) 

Workspace Developer User apex_dev apex 

Workspace Developer User brad.knight apex 

Workspace Administrator User susie.parker apex 

Workspace End User john.bell apex 

Note: The credentials mentioned above are for the users of the APEX Workspace. The 

first user (that is, apex_admin) is already created. You will be creating all the other 

users during the practices. 
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Practices for Lesson 1: Overview 

Overview 

 There are no practices for Lesson 1. 

 The OEHR schema is preinstalled in your workspace. 

 The files used in the practices are available in the /home/oracle/labs/labs directory. 

 The solution files for the practices are available in the /home/oracle/labs/solutions 

directory. 

 Practice 3-2 is an optional practice and does not have a solution script. 
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Practices for Lesson 2: Overview 

Overview 

There are three practices for this lesson. In these practices, you sign in and use Oracle 

Application Express as a Workspace Administrator and then as a Developer. 
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Practice 2-1: Using Oracle Application Express as a Workspace 

Administrator 

Overview 

As a new user, you are given access to Oracle APEX as a Workspace Administrator. To 

develop GlobalMart Management Tool (GMT), you need a Developer user. Therefore, you sign 

in to Oracle APEX as a Workspace Administrator and create a new user, Developer. 

Assumptions 

None 

Tasks 

1. Sign in to Oracle Application Express with the following details: 

 Workspace: APEX 

 Username: apex_admin 

 Password: <mentioned in the password document> 

2. Create a developer user with the following details: 

 Username: apex_dev 

 Password: <mentioned in the password document> 

 Email: apexdev@oracle.com 
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Practice 2-2: Using Oracle Application Express as a Developer 

Overview 

By now, you have created the apex user as a developer. Before getting into developing the 

GMT application, you should familiarize yourself with using Oracle APEX as a developer. To 

achieve this, in this practice, you: 

 Sign in to Oracle Application Express as a developer user 

 Run the sample database application 

 Install a packaged application and use it 

 Remove the packaged application from the workspace 

Assumptions 

You have completed Practice 2-1.  

Note: If you haven’t completed the previous practices, execute the steps mentioned in the 

Catch Up section of this practice. 

Tasks 

1. Sign in to Oracle Application Express with the following details: 

 Workspace: APEX 

 Username: apex_dev 

 Password: <mentioned in the password document> 

2. Install and Run the Sample Database Application, which is already available in your 

workspace. 

3. Install and use a packaged application. You install and use Customer Tracker available 

under packaged applications in your workspace. 

4. Remove the Customer Tracker packaged application from your workspace. 

Catch Up 

If you haven’t completed Practice 2-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_admin user. 

b. Click the arrow next to SQL Workshop and select SQL Scripts. 

c. Click the Upload > button. 

d. Browse and upload the sol_02_01.sql file in the /home/oracle/labs/solutions 

directory. 

e. Run the script by clicking the Run icon to create the apex user. 

f. Click Run Now. 

g. Make sure that the script executed successfully and the apex_dev user is created. 
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Practice 2-3: Installing a Sample Dataset 

Overview 

Oracle Application Express includes four sample datasets. Each dataset includes sufficient data 

to enable you to build applications with pages containing different types of components. 

With a few clicks of the mouse you can install, refresh, replace, or remove sample datasets in 

one of the schemas associated with your workspace. 

Assumptions 

You have completed Practice 2-1.  

Tasks 

1. Sign in to Oracle Application Express with the following credentials: 

 Workspace: APEX 

 Username: apex_dev 

 Password: <mentioned in the password document> 

2. Install the sample dataset HR Data from SQL Workshop Utilities in the OEHR schema.  

Catch up 

If you haven’t completed Practice 2-2, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_admin user. 

b. Click the arrow next to SQL Workshop and select SQL Scripts. 

c. Click the Upload > button. 

d. Browse and upload the sol_02_01.sql file in the 

/home/oracle/labs/solutions directory. 

e. Run the script by clicking the Run icon to create the apex_dev user. 

f. Click Run Now. 

g. Make sure that the script executed successfully and the apex_dev user is created. 
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Solution 2-1: Using Oracle Application Express as a Workspace 

Administrator 

Overview 

In this practice solution, steps are provided to create a new developer user by logging in as a 

Workspace Administrator. 

Steps 

1. Sign in to Oracle Application Express with the following details: 

 Workspace: Enter apex 

 Username: Enter apex_admin 

 Password: <mentioned in the password document> 

a. Open a browser and enter the following URL in the address bar: 

http://localhost:8080/apex/ 

 

b. On the Sign in page, enter apex for Workspace, apex_admin for Username, and the 

password (as mentioned in the password document). Click Sign In.  
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c. On your first login, you will be prompted to change your password. Enter the current 
password and new password. 

.  

d. Click Apply Changes. 
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e. You have successfully logged in to the Oracle Application Express workspace as a 
workspace administrator. You can sign out of the workspace and sign in with your new 
password.  

 

Click the Return to Sign In Page button and sign in again. 
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2. Create a developer user with the following details:  

 Username: Enter apex_dev 

 Password: <mentioned in the password document> 

 Email: Enter apexdev@oracle.com 

a. Click the Administration icon  present in the top-right corner of the page and 
select Manage Users and Groups from the drop-down menu. 

 

b. Click Create User >. 

 

c. Enter apex_dev in the Username field and enter apexdev@oracle.com in the  

Email Address field. 
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d. Scroll down and set the Default Schema to OEHR. Remove text from the Accessible 

Schemas field to make it null. Ensure that User is a workspace administrator is set 
to No and User is a developer is set to Yes. 

 

e. In the Password section, set the password in the Password field. Enter the same 
password in the Confirm Password field. In Require Change of Password on First 
Use, select No. 
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f. In the Group Assignments section, click >> to assign the OAuth2 Client 

Developer, RESTful Services, and SQL Developer roles to the user.  

 

g. Go to the top of the page and click Create User. After the user is created, the message 
User created appears.  
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h. Click the Account Menu icon  present in the top-right corner of the page and click 
Sign out. 

 

You have successfully created a developer user by signing in to the Oracle Application 

Express workspace as a workspace administrator. 
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Solution 2-2: Using Oracle Application Express as a Developer 

Overview 

In this practice solution, steps are provided to: 

 Sign in to Oracle Application Express as a developer user 

 Run the sample database application 

 Install a packaged application and use it 

 Remove the packaged application from the workspace 

Steps 

1. Sign in to Oracle Application Express with the following details: 

 Workspace: Enter APEX 

 Username: Enter apex_dev 

 Password: <mentioned in the password document> 

a. Click the Return to Sign In Page button. 
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b. Enter apex for Workspace and enter the apex_dev user credentials. Click Sign In. 

 

 

2. Install and Run the Sample Database Application, which is already available in your 

workspace.  

a. To install the Sample Database Application, go to App Gallery.  

 

b. In App Gallery, click Sample Apps.  
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c. Under Sample, click Sample Database Application. 
 

 

d. Click Install App. 

 

e. In the Install App Wizard, ensure that, under Authentication, Application Express 
Account is selected. Click Next >. 
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f. Click Install App. The installation process begins. 
 

 

g. After the installation is complete, the following message “Application installed” is 
displayed. You can run the Sample Database Application by clicking the Run icon.  
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h. You are prompted to enter your login credentials to sign in to the application. Enter 
your Application Express Developer Username and Password and click Sign In. 

 

i. The Sample Database Application opens. Click the various tabs and understand what 
the application does. 

 

After you have explored the application, close the browser. You have successfully run 
the sample database application. 
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3. Install and use a packaged application. You install and use Customer Tracker available 

under packaged applications in your workspace. 

a. Click the arrow next to App Gallery in the navigation bar and select Productivity 
Apps. 
 

 

b. You find a set of packaged applications that are available for you to install. In this 
activity, you install the Customer Tracker application. Click Customer Tracker. 

 

c. A description about the application is available. Read the description and click Install 
Application. 
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d. Retain the default authentication and click Next >. 

 

e. Click Install App. 

 

f. After the application is installed successfully, click the Run icon . 
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g. Enter your login credentials to sign in to the application (if prompted) and click Sign In. 
 

 

O
ra

cl
e 

In
te

rn
al

 &
 O

ra
cl

e 
Ac

ad
em

y 
U

se
 O

nl
y



 

Copyright © 2019, Oracle and/or its affiliates. All rights reserved. 

Practices for Lesson 2: Introducing Oracle Application Express  31 

h. You are taken to the Welcome page of the application. You must do the first-time 
setup:  

i. Under Access Control, click Contributor access for any authenticated 
user. 

ii. Under Users, click Add User to add a new user for Customer Tracker. In 
the screenshot below, you can see that apex_dev is added as an 
Administrator. In this practice, apex_member is added as a Contributor. 
To add more users, click Add User. 
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iii. Under Sample Data, click Yes – Load Sample Data. 

 

iv. Under Application Options, select Yes to enable the following options:  
Competitors, Contacts, Feedback, Geography, and Partners.   
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v. Click Complete Set Up. 

 

i. After the setup is completed, you are signed in to the application.  

 

 

O
ra

cl
e 

In
te

rn
al

 &
 O

ra
cl

e 
Ac

ad
em

y 
U

se
 O

nl
y



 

Copyright © 2019, Oracle and/or its affiliates. All rights reserved. 

34  Practices for Lesson 2: Introducing Oracle Application Express 

j. Explore the Customer Tracker application. You can do the following:  

 Click Add Customer to add new customers.  

 Click  to view the page in Card view.  

 Click  to view the page in Logo view.  

 Click   to view the page in Report view.  

 

k. Go to the top-right corner of the application and click Sign Out. Close the browser. 
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4. To remove the Customer Tracker packaged application from your workspace: 

a. Go to App Gallery and then click Productivity. Click the Customer Tracker 
application.  

 

b. On the Customer Tracker page, click Manage.  

 

c. Click Remove.  
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d. Click Remove Application to confirm. 

 

Wait until the application is removed completely. After the application is removed, the 

message “Application removed” is displayed.  
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Solution 2-3: Installing a Sample Dataset 

Overview 

In this practice solution, steps are provided to: 

 Sign in to Oracle Application Express as a developer user. 

 Install the sample dataset HR Data in the OEHR schema. 

Steps 

To install the sample dataset: 

1. On the Oracle Application Express Workspace home page, click SQL Workshop.   

 

2. Select Utilities and click Sample Datasets.  
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3. On the Sample Datasets page, find the dataset HR Data and click Install. If the sample 

dataset is already installed, click Update.  

 

4. On the Manage Sample Datasets page, select options for: 

a. Language: Select English 

Schema: Select your schema OEHR.  

b. Click Next. The Load Sample Dataset page opens, displaying the database 

object that will be installed.     
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5. Click Install Dataset. 

 
 

6. The Load Sample Dataset - Results page appears. At this point, you can create an 

application or exit. Click Exit.  

 

The Sample Dataset page displays again. This completes the task of loading Project 

Data sample dataset.  

Note: The Action column now displays Update instead of Install. 

Tip: You can click Update to refresh a sample dataset or remove it. 
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Practices for Lesson 3: Overview 

Overview 

In these practices, you create a database application. You also create a database application by 

using a spreadsheet. 
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Practice 3-1: Creating Database Applications 

Overview 

In this practice, you create GlobalMart Management Tool (GMT). 

Assumptions 

You have completed the previous practices.  

Note: If you haven’t completed the previous practices, execute the steps mentioned in the 

Catch Up section of this practice. 

Tasks 

1. Create a database application named GlobalMart Management Tool. The Application ID 

entered here is 111; In the rest of the practices in this course, you will enhance and 

complete this application by creating pages, regions, processes, and so on. 

Catch Up 

If you haven’t completed Practice 2-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_admin user. 

b. Click the arrow next to SQL Workshop and select SQL Scripts. 

c. Click the Upload > button. 

d. Browse and upload the sol_02_01.sql file in the 

/home/oracle/labs/solutions directory. 

e. Run the script by clicking the Run icon. 

f. Click Run Now. 

g. Make sure that the script executed successfully and the apex_dev user is created. 

 

If you haven’t completed Practice 2-3: Installing a Sample Dataset, perform the steps to 

install a sample dataset before you start with Practice 3-1. 
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Practice 3-2: Creating a Database Application from a File 

Overview 

In this practice, you create a database application from a file. 

Assumptions 

You have completed the previous practices.  

Note: If you haven’t completed the previous practices, execute the steps mentioned in the 

Catch Up section of this practice. 

Tasks 

1. Create a database application from a file. You create an application named Tasks based 

on the tasks.txt file available in the /home/oracle/labs/labs/ folder. The file has 

tab-delimited information, and the first row contains the column names. Name the table, 

where the data from the file is uploaded, Tasks. 

Catch Up 

If you haven’t completed Practice 2-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_admin user. 

b. Click the arrow next to SQL Workshop and select SQL Scripts. 

c. Click the Upload > button. 

d. Browse and upload the sol_02_01.sql file in the 

/home/oracle/labs/solutions directory. 

e. Run the script by clicking the Run icon. 

f. Click Run Now. 

g. Make sure that the script executed successfully and the apex_dev user is created. 

 

If you haven’t completed Practice 2-3: Installing a Sample Dataset, perform the steps to 

install a sample dataset before you start with Practice 3-2. 

 

If you haven’t completed Practice 3-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_dev user. 

b. Click the arrow next to Application Builder and select Import. 

c. Click the Browse button. 

d. Browse and open the sol_03_01.sql file in the /home/oracle/labs/solutions 

directory and click Next >. 

e. Click Next >. 

f. Select Reuse Application ID 111 From Export File for the Install As Application 
option and click Install Application. 

g. Click Replace Application (if prompted). 

h. Wait for the application to successfully install. 
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Solution 3-1: Creating Database Applications 

Overview 

In this practice solution, steps are provided for creating the GlobalMart Management Tool 

application. 

Steps 

1. Create a database application named GlobalMart Management Tool. In the rest of the 

practices in this course, you will enhance and complete this application by creating pages, 

regions, processes, and so on. 

a. Select the App Builder pull-down menu and click Create. 
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b. In the Create Application Wizard, click New Application.  

 

c. In the Create an Application Wizard, enter the following:  

 Name: Enter GlobalMart Management Tool. 

 Click Set Appearance  to customize the apprerance of the application. 

 

d. Scroll down the Create App Wizard page and enter the following under Settings: 

 In the Application ID field, enter 111.  

 In the Schema field, select OEHR. 

o Note: Throughout the course, the application ID remains 111.  
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 Click Create Application.  

 

 

e. The GlobalMart Management Tool application is created. By default, the following three 
pages are created:  

 Global Page – 0 – Global Page – Desktop 

 Home page – 1 - Home  

 Login page – 9999 – Login page 
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Solution 3-2: Creating a Database Application from a File 

Overview 

In this practice solution, steps are provided for creating a database application from a file. 

Note: Practice 3-2 is an optional practice and does not have a solution script. 

Steps 

1. Create a database application from a file. You create an application named Tasks based 

on the tasks.txt file available in the /home/oracle/labs/labs/ folder. The file has 

tab-delimited information and the first row contains the column names. Name the table, 

where the data from the file is uploaded, Tasks. 

a. Select the App Builder pull-down menu and click Create. 
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b. In the Create Application Wizard, click From a File.  
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c. The Load Data page opens. You can either upload a file or copy and paste a file. Here 
we select Upload a File tab. You can either drag and drop file or select the Choose 
File option. Here we click Choose File.  

 

d. Select tasks.txt file from the /home/oracle/labs/labs/ folder. The Load Data 

page opens with a preview. Click Load Data.  

 
The Load Data page opens with a preview of rows and columns.  
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e. Enter the following details under Load to Table and click Load Data:  

 Table Owner: Select OEHR 

 In the Table Name field, enter DEMO_ORDER_TYPE.  

 The Error Table Name field gets populated by default as 
DEMO_ORDER_TYPE_ERR$. 

 

You get the message DEMO_ORDER_TYPE created with 80 rows. Click Continue 

to Create Application Wizard. 
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2. The Create Application page appears. You can now start creating your application. In 
the Create App Wizard, ensure that Application Name is TASKS. 

 

3. Click Create Application.  

 

4. To view the application, click Run Application. 
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a. Enter the developer user credentials and click Sign in. 

 

b. The home page of the TASKS application is displayed. Click the Order Type. It 
displays an interactive report by using the data from the file (tasks.txt). Click Home on 
the Developer toolbar to return to the development environment.  
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Practices for Lesson 4: Overview 

Overview 

In these practices, you create Classic reports and two reports optimized for Smartphones, a 

Column Toggle report and a List View report. 
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Practice 4-1: Creating Classic Reports 

Overview 

In this practice, you create a: 

 Classic report for GMT application (called Top Tier Salary) by using a SQL query 

 Classic report (called Customer Address List) for GMT application by selecting a table 

Assumptions 

You have completed the previous practices.  

Note: If you have not completed the previous practices, execute the steps mentioned in the 

Catch Up section of this practice. 

Tasks 

1. On a new page in the GMT application, create a Classic report by using a SQL query. 

Name the new page and the report Top Tier Salary. The report should display the last 

name, email, and salary of employees who earn between $5000 and $12000 from the OEHR 

_EMPLOYEES table. 

2. On a new page in the GMT application, create a Classic report by using the source type as 

Table. Name the page and the report Customer Address List. The report should display 

the address information of the customers, such as the first and last names, address, city, 

and state from the OEHR_CUSTOMERS table. 

3. Modify the Customer Address List report with the following requirements: 

 Rename the report region Customer Address List. Then change the report headings for 

CUST_FIRST_NAME and CUST_LAST_NAME to First Name and Last Name, 

respectively. 

 Change the Pagination to Row Ranges X to Y of Z (with pagination). 

 Review the query definition and add the COUNTRIES.COUNTRY_NAME column to the 

report. 

Hint: You will need to create a join. 

Catch Up 

If you have not completed Practice 2-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_admin user. 

b. Click the arrow next to SQL Workshop and select SQL Scripts. 

c. Click the Upload button. 

d. Browse and upload the sol_02_01.sql file in the 

/home/oracle/labs/solutions directory. 

e. Run the script by clicking the Run icon. 

f. Click Run Now. 

g. Make sure that the script executed successfully and the apex_dev user is created. 
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If you haven’t completed Practice 2-3: Installing a Sample Dataset, perform the steps to 

install a sample dataset before you start with Practice 4-1. 

 

If you have not completed Practice 3-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_dev user. 

b. Click the arrow next to App Builder and select Import. 

c. For Import File, click the button and browse to the sol_03_01.sql file in the 

/home/oracle/labs/solutions directory and click Next. 

d. Click Next. 

e. For Install As Application, select Reuse Application ID 111 From Export File and 
click Install Application. 

f. Click Replace Application (if prompted). 

g. Wait for the application to successfully install. 
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Practice 4-2: Creating a Column Toggle Report 

Overview 

In this practice, you create a new page containing a Column Toggle report for the GMT 

application. Column Toggle reports feature a responsive report optimized for mobile applications 

and Smartphones. You will deselect a few columns to hide them in the report. Then you will 

select those columns again to show them in the report. 

Assumptions 

You have completed the previous practices. 

Note: If you have not completed the previous practices, execute the steps mentioned in the 

Catch Up section of this practice. 

Tasks 

1. On a new page in the GMT application, create a Column Toggle Report. Enter Product 

Information as the Page Name. Change the Page Number to 202. The report should 

select all the columns from the OEHR_PRODUCT_INFORMATION table.  

 After the page is created, run the page to view the Product Information report with all 

the columns from OEHR_PRODUCT_INFORMATION displayed. Check out the 

responsive nature of the report. 

 Using the Columns option in the report, hide the columns Product Description, 
Category ID, and Supplier ID from the report. 

Catch Up 

If you have not completed Practice 2-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_admin user. 

b. Click the arrow next to SQL Workshop and select SQL Scripts. 

c. Click the Upload button. 

d. Browse and upload the sol_02_01.sql file in the 

/home/oracle/labs/solutions directory. 

e. Run the script by clicking the Run icon. 

f. Click Run Now. 

g. Make sure that the script executed successfully and the apex_dev user is created. 

 

If you haven’t completed Practice 2-3: Installing a Sample Dataset, perform the steps to 

install a sample dataset before you start with Practice 4-2. 
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If you have not completed Practice 4-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_dev user. 

b. Click the arrow next to App Builder and select Import. 

c. For Import File, click the button and browse to the sol_04_01.sql file in the 

/home/oracle/labs/solutions directory and click Next. 

d. Click Next. 

e. For Install As Application, select Reuse Application ID 111 From Export File and 
click Install Application. 

f. Click Replace Application (if prompted). 

g. Wait for the application to successfully install. 
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Practice 4-3: Adding and Modifying a List View Report 

Overview 

In this practice, you create a list of employees by creating a List View report. List View reports 

feature a responsive design to display data and provide easy navigation on Smartphones. 

Assumptions 

You have completed the previous practices.  

Note: If you have not completed the previous practices, execute the steps mentioned in the 

Catch Up section of this practice. 

Tasks 

1. On a new page in the GMT application, create a List View report. Enter Employee List 

as the Page Name. Change the Page Number to 201. The list view should select all the 

columns from the OEHR_EMPLOYEES table and should display the last names as the text 

column. The list view should also be enabled to search the last name column with the 

Search Type Like & Ignore Case. 

Catch Up 

If you have not completed Practice 2-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_admin user. 

b. Click the arrow next to SQL Workshop and select SQL Scripts. 

c. Click the Upload > button. 

d. Browse and upload the sol_02_01.sql file in the 

/home/oracle/labs/solutions directory. 

e. Run the script by clicking the Run icon. 

f. Click Run Now. 

g. Make sure that the script executed successfully and the apex_dev user is created. 

 

If you haven’t completed Practice 2-3: Installing a Sample Dataset, perform the steps to 

install a sample dataset before you start with Practice 4-3. 

 

If you have not completed Practice 4-2, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_dev user. 

b. Click the arrow next to App Builder and select Import. 

c. For Import File, click the button and browse to the sol_04_02.sql file in the 

/home/oracle/labs/solutions directory and then click Next. 

d. Click Next. 

e. For Install As Application, select Reuse Application ID 111 From Export File and 
click Install Application. 

f. Click Replace Application (if prompted). 
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g. Wait for the application to successfully install. 
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Solution 4-1: Creating Classic Reports 

Overview 

In this practice solution, you create Classic reports for the GlobalMart Management Tool (GMT) 

application. 

Steps 

1. On a new page in the GMT application, create a Classic report by using a SQL query. 

Name the new page and the report Top Tier Salary. The report should display the last 

name, email, and salary of employees who earn between $5000 and $12000 from the 

OEHR_EMPLOYEES table. 

a. On the Workspace home page, click App Builder, select the GlobalMart 
Management Tool application, and click Create Page. 

 

b. For Page Type, select Report. 
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c. Select Classic Report. 

 

d. Update the following Page Attributes: 

 Page Number: Enter 2. 

 Page Name: Enter Top Tier Salary. 

 

e. Click Next >. 
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f. For Navigation Menu, accept the default and click Next. 

 

g. For Source Type, select SQL Query. 

h. Create the query using Query Builder. Click the Query Builder icon . 

 

i. In the Object Selection pane (left pane), select OEHR_EMPLOYEES. 

j. Select the check boxes to select the following columns: 

 LAST_NAME 

 EMAIL 

 SALARY 
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On the Conditions tab, for the SALARY > Condition, enter BETWEEN 5000 and 

12000 and click Run in the top-right corner. 

 

The results of the query are displayed on the Results tab at the bottom of the screen. 

k. Click Return on the top right of the screen.  
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l. The query appears in the Enter a SQL SELECT statement field. Click Create. 

  

 

m. Page Designer appears, displaying the new page. Click the Save and Run Page. 

 

If prompted, enter your developer credentials. 
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n. Review the report. When finished, click Application 111 on the Runtime Developer 
toolbar (at the bottom of the page) to return to your application home page. 

 

 

 

2. Create another classic report on a new page, but this time select the source type, Table. 

Name the page and the report Customer Address List. The report should display the 

address information of the customers, such as the first and last names, address, city, and 

state from the OEHR_CUSTOMERS table. 

a. On the Application home page, click Create Page. 

 

O
ra

cl
e 

In
te

rn
al

 &
 O

ra
cl

e 
Ac

ad
em

y 
U

se
 O

nl
y



 

Copyright © 2019, Oracle and/or its affiliates. All rights reserved. 

Practices for Lesson 4: Creating Classic Reports  69 

b. Select Report.  

 

c. Select Classic Report. 

 

d. Update the following attributes: 

 Page Number: Enter 3. 

 Page Name: Enter Customer Address List. 

 Click Next >. 
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e. For Navigation Menu, accept the default and click Next. 

 

f. For Source Type, select Table.  
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g. For Table / View Name, click the icon  to open a Search dialog box.  

 

h. Select OEHR_CUSTOMERS (table). 
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i. Click the Columns region to expand it. 

  

j. By default, the wizard selects all the columns. Move all the columns to the left by 

clicking the double-left arrow (<<) labeled Remove All. 
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k. Deselect all the columns.  

l. Select the columns to include in the report. Press and hold the Ctrl key and click the 

following items: 

 CUST_FIRST_NAME 

 CUST_LAST_NAME 

 STREET_ADDRESS 

 CITY 

 STATE_PROVINCE 
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m. Click the right arrow (>) labeled Move. The selected columns appear on the right.  
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n. Click Create.  

 

o. Page Designer appears. Click the Save and Run Page. 
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p. Review the report. When finished, click Edit Page 3 on the Runtime Developer toolbar 

to return to Page Designer. 
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3. Modify the Customer Address List report with the following requirements: 

 Change the report region from the default Report 1 to Customer Address List. 

 Change the report headings for CUST_FIRST_NAME and CUST_LAST_NAME to First 

Name and Last Name, respectively. 

a. On the Rendering tab (the left pane), under Regions > Content Body, select  

Report 1. 

 

b. In the Property Editor (the right pane), under Identification > Title, enter Customer 

Address List. 
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c. Change the heading for the CUST_FIRST_NAME column. 

 On the Rendering tab (the left pane), under Regions > Content Body > 

Customer Address List, expand Columns and select CUST_FIRST_NAME. 

 

 In the Property Editor (right pane), change Heading > Heading to First Name. 
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d. Change the heading for the CUST_LAST_NAME column.  

 On the Rendering tab (left pane), under Regions > Content Body > Customer 

Address List > Columns, select CUST_LAST_NAME. 

 

 In the Property Editor, change Heading > Heading to Last Name. 
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4. Change the Pagination to Row Ranges X to Y of Z (with pagination). 

a. On the Rendering tab, under Regions > Content Body > Customer Address List, 
select Attributes. 

b. In the Property Editor, under the Pagination > Type, select Row Ranges X to Y of Z 
(with pagination).  

c. Click the Save button (top-right corner). 

 

 

5. Review the query definition and add the OEHR_COUNTRIES.COUNTRY_NAME column to the 

report. 

Hint: You will need to create a join. 
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a. On the Rendering tab, under Regions > Content Body, select Customer Address 
List. 

  

b. In the Property Editor, under Source > Type, select SQL Query. A SQL Query attribute 
and field appear. 

c. Modify the query definition using Query Builder. Under Source > SQL Query, click the 

Code Editor: SQL Query icon . 
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d. Click the Query Builder icon . A warning is displayed. Click Create to proceed. 

 

 

e. On the Object Selection pane (on the left side of the page), select OEHR_CUSTOMERS 

and OEHR_COUNTRIES. 

f. In the OEHR_CUSTOMERS table, select the CUST_FIRST_NAME, CUST_LAST_NAME, 

STREET_ADDRESS, CITY, and STATE_PROVINCE columns. 
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g. In the OEHR_COUNTRIES table, select the COUNTRY_NAME column. 

 

h. Join the tables by clicking the join column field to the right of the COUNTRY_ID entry 

in both the tables. 
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i. Click Run and then Return in the top right of the screen.  

 

 

j. Click OK to commit the new query.  

k. The SQL updates in the SQL Query field in the Property Editor. Click the Save and 

Run Page. 
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l. Note the changes that you made to the report. Click Edit Page 3 on the Runtime 

Developer toolbar to return to Page Designer. 
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Solution 4-2: Creating a Column Toggle Report 

Overview 

In this practice solution, you create a new page containing a Column Toggle report for your 

GlobalMart Management Tool (GMT) application. Column Toggle reports feature a responsive 

report optimized for mobile applications and Smartphones. By default, column toggle reports are 

created with all columns set to the same priority. However, the developer can edit the report 

column attributes and rank columns by importance.  

Steps 

1. Create a new page in the GMT application containing a Column Toggle report. Enter 

Product Information as the Page Name. Change Page Number to 202. The report should 

select all the columns from the OEHR_PRODUCT_INFORMATION table. 

a. Return to Page Designer (already open in another window). From the Page Designer 

toolbar, select Create  and then Page. 
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b. Click Report. 

 

c. Click Column Toggle Report. 
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d. Change Page Number to 202. For Page Name, enter Product Information. 

 

e. Click Next >. 

For Navigation menu, accept the defaults and click Next >. 

 

f. For Source Type, click Table. 
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g. From Table / View Name, click the  icon to open a search dialog box and select 

OEHR_PRODUCT_INFORMATION (table). By default, all columns are selected. 

 

h. Click Create. Click the Save and Run Page to view the report. 

 

 

Note: If prompted, enter your developer credentials. 

All the columns from PRODUCT_INFORMATION table appear. 

i. Try out the responsive nature of the report. Slowly reduce the size of the browser 

horizontally. Notice that the column starts disappearing from the right side (that is, 

starting from the Catalog URL field) as the size of the browser is being reduced. 

 

2. Using the Columns option in the report, hide the columns Product Description, Category ID, 

and Supplier ID from the report. 

O
ra

cl
e 

In
te

rn
al

 &
 O

ra
cl

e 
Ac

ad
em

y 
U

se
 O

nl
y



 

Copyright © 2019, Oracle and/or its affiliates. All rights reserved. 

90  Practices for Lesson 4: Creating Classic Reports 

a. On the Product Information Page, click Columns and then click the following columns 

to deselect them: 

 Product Description 

 Category Id 

 Supplier Id 

 

b. Click anywhere on the page to close the Columns list. Notice that the columns that you 

deselected are hidden in the report. 

 

c. The column toggle report is complete. Click Application 111 on the Runtime 

Developer toolbar to return to the Application home page. 
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Solution 4-3: Adding and Modifying a List View Report 

Overview 

In this practice solution, you add and modify a List View report in your GlobalMart Management 

Tool (GMT) application. List View reports feature a responsive design to display data and 

provide easy navigation on Smartphones. 

Steps 

1. On a new page in the GMT application, create a List View report. Enter Employee List as 

the Page Name. Change Page Number to 201. 

a. Navigate to the Application home page and click Create Page. 

 

b. Click Report. 
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c. Click List View. 

 

d. Change Page Number to 201 and in Page Name enter Employee List. 

 

e. Click Next >. 
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f. For Navigation Menu, accept the defaults and click Next >. 

 

g. For Source Type, select SQL Query. 

h. Under Enter Region Source, enter the following SQL SELECT statement (in the 

/home/oracle/labs/labs/lab_04_03_01.txt file): 

SELECT * from OEHR_EMPLOYEES 

 

i. Click Next >. 

 

2. The list view should select all the columns from the OEHR_EMPLOYEES table and should 

display the last names as the text column. The list view should also be enabled to search 

the last name column with the Search Type Like & Ignore Case.  

a. Under Features, select Enable Search and Inset List. For Text Column, select 

LAST_NAME to display the last name as the text column. For Search Type, select 

Server: Like & Ignore Case. 
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b. Click Create. The Page Designer opens, displaying Page 201 - Employee List. 

c. Click the Save and Run Page. 

 

Note: If prompted, enter your developer workspace credentials. 
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d. Review the List View report. 

 

e. Enter green in the search bar and press the Enter key to display the names 

containing “green.” Note the search results.  
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f. Clear the search field and press Enter to reset the report. 

g. This List View report is complete. Click Application 111 on the Runtime Developer 

toolbar to return to the Application home page. 
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Practices for Lesson 5: Overview 

Overview 

In these practices, you create, manipulate, and customize an interactive report to generate 

separate private, public, and default reports. 
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Practice 5-1: Creating and Manipulating an Interactive Report 

Overview 

In this practice, you create two interactive reports—Customer Report and Employee 

Commissions for GMT application. These two reports provide flexible customization for users. 

Assumptions 

You have completed the previous practices.  

Note: If you haven’t completed the previous practices, execute the steps mentioned in the 

Catch Up section of this practice. 

Tasks 

1. Create an interactive report to display all the columns from the OEHR_CUSTOMERS table on 

a new page in the GMT application. Name the page Customers. Perform the following 

customizations to the report: 

 Create a filter on the city of Philadelphia. 

 Create a highlight where the credit limit is greater than 2500. 

 Hide columns to display only the Customer ID, Customer Name, Address, Phone 
Number, and Credit Limit. 

 Delete the filter that you created first. 

 Sort the rows in ascending order by State. 

 Change the pagination to display all rows. 

 Create a Group By report to display the number of customers in a particular province or 
state. Change the pagination to display all rows. 

 Create a Pivot report to display the total credit limit of customers for each account 
manager. 

 Save the report as a private report called My Report. 

 Reset the Primary Report to its original state. 

 Create a new computation. The computation should add .15 to a commission of .1 

and .05 to a commission of .15. Use the following CASE statement to perform the 

computation (located in /home/oracle/labs/labs/lab_05_02_02.txt). 

2. Create an interactive report on a new page in the GMT application to display details 

(employee_id, first_name, last_name, manager_id, and commission_pct) 

from the OEHR_EMPLOYEES table about who earns a commission. Name the page and the 

report Employee Commissions. From the Create Report Wizard, create a breadcrumb for 

the page and select the Home page as the parent page. After creating the report, make the 

following customizations to the report: 

 Management proposes to increase the commission of employees whose existing 
commission percentage is less than or equal to 0.15. Create a computed column called 
New Commission, to display the new commission. The new commission scheme 
includes: 

 Employees with a commission percentage of 0.1 will get an additional commission of 
0.15. 
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 Employees with a commission percentage of 0.15 will get an additional 
commission of 0.05. 

 Create a control break on Manager ID. 

 Display the maximum commission earned by employees under each manager. 

 Download the HTML report. 

 Save all the customizations that you have made to this report so that it is available to 
other users, but is not the default report. Name the saved report Commission 
Proposal. 

 Reset the Primary Report. 

Catch Up 

If you haven’t completed Practice 2-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_admin user. 

b. Click the arrow next to SQL Workshop and select SQL Scripts. 

c. Click the Upload > button. 

d. Browse and upload the sol_02_01.sql file in the 

/home/oracle/labs/solutions directory. 

e. Run the script by clicking the Run icon. 

f. Click Run Now. 

g. Make sure that the script executed successfully and the apex_dev user is created. 

 

If you haven’t completed Practice 2-3: Installing a Sample Dataset, perform the steps to 

install a sample dataset before you start with Practice 5-1. 

 

If you have not completed Practice 4-3, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_dev user. 

b. Click the arrow next to App Builder and select Import. 

c. For Import File, click the button and browse to the sol_04_03.sql file in the 

/home/oracle/labs/solutions directory and click Next. 

d. Click Next. 

e. For Install As Application, select Reuse Application ID 111 From Export File and 
click Install Application. 

f. Click Replace Application (if prompted). 

g. Wait for the application to successfully install. 
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Practice 5-2: Customizing an Interactive Report 

Overview 

By now, you have created two reports (Customer Report and Employee Commissions) with 

features for customization at the users’ end. In this practice, you customize those two reports 

using all the features provided by Oracle Application Express. 

Assumptions 

You have completed the previous practices.  

Note: If you haven’t completed the previous practices, execute the steps mentioned in the 

Catch Up section of this practice. 

Tasks 

1. Make the following customizations to the Employee Commissions report: 

 Hide EMPLOYEE_ID and change MANAGER_ID to be the FIRST_NAME and 

LAST_NAME of the manager. 

 Remove the Highlight option from the Actions menu. 

 Run the report and confirm the changes that you made. 

Catch Up 

If you haven’t completed Practice 2-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_admin user. 

a. Click the arrow next to SQL Workshop and select SQL Scripts. 

b. Click the Upload > button. 

c. Browse and upload the sol_02_01.sql file to the 

/home/oracle/labs/solutions directory. 

d. Run the script by clicking the Run icon. 

e. Click Run Now. 

f. Make sure that the script executed successfully and the apex_dev user is created. 

 

If you haven’t completed Practice 2-3: Installing a Sample Dataset, perform the steps to 

install a sample dataset before you start with Practice 5-2. 

 

If you have not completed Practice 5-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_dev user. 

b. Click the arrow next to App Builder and select Import. 

c. For Import File, click the button and browse to the sol_05_01.sql file in the 

/home/oracle/labs/solutions directory and click Next. 

d. Click Next. 

e. For Install As Application, select Reuse Application ID 111 From Export File and 
click Install Application. 
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f. Click Replace Application (if prompted). 

g. Wait for the application to successfully install. 
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Solution 5-1: Creating and Manipulating an Interactive Report 

Overview 

In this practice solution, steps are provided to create and manipulate the interactive report for 

the GMT application. 

Steps 

1. Create an interactive report to display all the columns from the OEHR_CUSTOMERS 

table on a new page in the GMT application. Name the page Customers and the region 

Customer Report. 

a. Navigate to the GMT application home page and click Create Page. 

 

b. Select Report. 
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c. Select Interactive Report. 

 

a. In Report Page Number, enter 4; in Report Page Name, enter Customers. Click Next. 
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b. In Navigation Preference, select Create a new navigation menu entry. Notice that 

Customers is auto-populated in the New Navigation Menu Entry field. Click Next. 
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c. From Table / View Name, click the  icon to search for a table. In the Search dialog 

box, find and select OEHR_CUSTOMERS (table). Click Create. 

 

d. The report is created. To view the report, click the Save and Run Page icon . 

 

Note: If prompted, enter your developer user credentials. 

The interactive report is displayed. 
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2. Create a filter on the city of Philadelphia. 

a. Click the magnifying glass icon labeled Select columns to search and select City 

from the Column Selector. Note that the selected search term appears as placeholder 

text in the field (Search: City). If you did not select a column, the search criteria you 

enter in the next step would search all columns. 
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b. Enter phil in the search field and click Go. Note that the % wildcard is implied and is 

not entered. 

A filter is applied, and only the records that meet the search criteria are displayed. 
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3. Create a highlight where the credit limit is greater than 2500. 

a. To highlight only those customers whose credit limit is greater than 2500, click Actions 
and select Format > Highlight. 
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b. In Name, enter Good Credit Rating; in Background Color, select [yellow]; in 

Column, select Credit Limit; in Operator, select > (greater than), and in Expression, 

enter 2500. Click Apply. 

 

The records that meet the criteria are highlighted. (Scroll down to see them.) 
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4. Display only the Customer ID, Customer Name, Address, Phone Number, and Credit Limit 

by hiding the other columns in the report. 

a. Click Actions > Columns. 

b. Ctrl + select only the following columns: 

 Country ID 

 Cust Email 

 Nls Language 

 Nls Territory 

 Account Manager ID 
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c. Click the < icon (Remove) to move them to the Do Not Display area. Note that you can 

still perform other actions against these columns even though they are not displayed in 

the report. 
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d. Click Apply. 

Only the columns that were under the Display in Report area are displayed. 

 

 

5. Delete the “phil” filter. 

a. Click the X icon (Remove Filter) for the City contains ‘phil’ filter. 
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The report refreshes with the filter deleted. 

 

6. Display the rows in ascending order by State. 

a. Sort by State Province. Click the State Province column heading and click the Sort 
Ascending icon. 
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The report sorts the entries as per the state in ascending order. 
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7. Change the pagination to display all rows. 

a. Because the pagination is set to default (50), you do not see all the rows. To view all the 

rows, click Actions > Format > Rows Per Page > All. 
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8. Create a Group By report to display the number of customers in a particular province or 

state.  

a. To create a Group By report, click Actions and select Group By. 

 

b. Click Select Group By Column and select State Province. In Functions, select 

Count; in Column, select Customer Id; and in Label, enter Number of Customers. 

Click Apply. 
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c. The state provinces and the number of customers per state appear. To return to the 

report view, click the View Report icon .  

 

 

9. Create a Pivot report to display the total credit limit of customers for each account manager 

to see how much potential debt you may hold. 

a. To create a Pivot, click Actions > Pivot. 

O
ra

cl
e 

In
te

rn
al

 &
 O

ra
cl

e 
Ac

ad
em

y 
U

se
 O

nl
y



 

Copyright © 2019, Oracle and/or its affiliates. All rights reserved. 

120  Practices for Lesson 5: Creating Interactive Reports 

  

b. In the Pivot dialog box:  

 In Pivot Columns, select Account Manager Id 

 In Row Columns, select Customer Id 

 In Functions, select Sum 

 In Column, select Credit Limit 

 In Label, enter Total Credit Limit 

 In Sum, select the check box to enable 
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c. Click Apply. 

The credit limits for each customer per manager are displayed with an aggregation row 

at the bottom with the total amount of credit each manager has allocated. 

 

 

d. To return to the report view, click the View Report icon . 
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10. Save the report as a private report that is available only to you. 

a. Click Actions > Report > Save Report. 

  

b. In Name, enter My Report. Click Apply. 
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c. The report is saved. You can click the Reports drop-down list to see the list of reports. 

 

 

11. Reset the Primary Report to its original state. 

a. Click the Reports drop-down menu (1. My Report) and select 1. Primary Report. 
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b. To return to the default settings, click Actions > Report > Reset. 

 

c. Click Apply. 

 

You see the original report without customizations. 

  

O
ra

cl
e 

In
te

rn
al

 &
 O

ra
cl

e 
Ac

ad
em

y 
U

se
 O

nl
y



 

Copyright © 2019, Oracle and/or its affiliates. All rights reserved. 

Practices for Lesson 5: Creating Interactive Reports  125 

d. Click the Application 111 link at the bottom of the page to return to the Application 
home page. 
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12. Create a stand-alone interactive report page with breadcrumbs in the GMT application 

named Employee Commissions. This interactive report displays details from the 

OEHR_EMPLOYEES table about who earns a commission. 

a. Navigate to the GMT application home page and click Create Page.   

b. Select Report. 

  

c. Select Interactive Report. 
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a. In Page Number, enter 5; in Page Name, enter Employee Commission; in 

Breadcrumb, select Breadcrumb; and in Parent Entry, select Home (Page 1). Click 

Next. 

 

b. In Navigation Preference, accept the default settings and click Next. 

c. In Source Type, select SQL Query. Enter the following SQL SELECT statement. You 

can copy and paste the SQL statement from 

/home/oracle/labs/labs/lab_05_01_01.txt. Alternatively, you can use the 

Query Builder button to create the report query. 

SELECT employee_id, first_name, last_name, manager_id, 

commission_pct 

FROM OEHR_EMPLOYEES 

WHERE commission_pct IS NOT NULL; 
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d. Click Create. The report is created. 

e. To view the report, click the Save and Run Page icon. 

 

Note: If prompted, enter your developer user login credentials. 

Your report is displayed. 
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13. Management proposes to increase the commission of employees whose existing 

commission percentage is less than or equal to 0.15. Create a computed column called 

New Commission, to display the new commission. The new commission scheme includes: 

 Employees with a commission percentage of 0.1 will get an additional 

commission of 0.15. 

 Employees with a commission percentage of 0.15 will get an additional 

commission of 0.05. 

a. To create a new computation, click Actions > Data > Compute. 

 

b. For Column Label, enter New Commission. 

c. The computation should add .15 to a commission of .1 and .05 to a commission of .15. 

For Computation Expression, enter the CASE statement (located in 

/home/oracle/labs/labs/lab_05_01_02.txt): 

CASE E WHEN 0.1 THEN E+0.15 WHEN 0.15 THEN E+0.05 ELSE E END 

You can use the columns list, functions list, and keypad to enter the code in the 

computation area or paste the previous CASE statement into the computation area. 

When you select Commission Pct from Columns, notice that the letter corresponding to 

the column appears in the computation area. This is the column alias. 

After entering the code, click Apply. 
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The computed column appears in the report. 
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14. Create a control break on Manager ID. 

a. Click the Manager Id column heading and click the Control Break icon. (To more fully 
configure a control break, you can click Actions > Format > Control Break.) 

 

The column now appears before each break point in the report. 
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15. Display the maximum commission earned by employees under each manager. 

a. To find out the maximum commission earned by employees under each manager, click 

Actions > Data > Aggregate. 
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b. In Function, select Maximum, and in Column, select **New Commission (a computed 

column from the column list). 

  

c. Click Apply. 

The report includes the maximum commission earned by employees under each 

manager. 
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16. Download the HTML report. 

a. To download a report, click Actions and select Download. 

  

b. Click HTML. 
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c. Open the file to view the report in your web browser. 

 

d. Close the HTML report. 

e. Click Cancel to close the Download window. 
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17. Save this as a public report. Name the saved report Commission Proposal. 

a. Click Actions > Report > Save Report. 

b. In the Save drop-down list, select As Default Report Settings. 

 

The Save Report dialog changes to Save Default Report. 

c. In Default Report Type, select Alternative, and in Name, enter Commission 

Proposal. Click Apply. 
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The alternative report now appears in the Reports drop-down list. 

 

 

18. Reset the Primary Report. 

a. Click the Reports drop-down list and select 1. Primary Report. 

 

b. To reset this primary report to its original settings, click Actions > Report > Reset. 

c. Click Apply. 
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d. The primary report is reset to its original settings. Click Edit Page 5 on the Runtime 

Developer toolbar at the bottom of the page to return to Page Designer. 
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Solution 5-2: Customizing an Interactive Report 

Overview 

In this practice solution, steps are provided to customize the interactive report that you created 

for the GMT application. 

Steps 

1. Make the following customizations to the Employee Commissions report:  

 Hide EMPLOYEE_ID. 

 Change MANAGER_ID to be the FIRST_NAME and LAST_NAME of the manager. 

a. Navigate to the Page Designer view of the Employee Commission page. 

b. On the Rendering tab (left pane), expand Regions > Content Body and select 

Employee Commission. 
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c. In the Property Editor (right pane), in the Source section, change the SQL Query field 

value to reflect the following query (located in 

/home/oracle/labs/labs/lab_05_02_01.txt): 

SELECT e.employee_id, 

e.first_name, 

e.last_name, 

(SELECT e1.first_name||' '||e1.last_name from 

OEHR_EMPLOYEES e1 where e1.employee_id =  

e.manager_id) as 

"Manager", 

e.commission_pct 

FROM OEHR_EMPLOYEES e 

where e.commission_pct IS NOT NULL; 
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d. On the Rendering tab (left pane), expand Regions > Content Body > Employee 

Commission > Columns and select EMPLOYEE_ID. 

 

e. In the Property Editor (right pane), under Identification, click the Type drop-down list 

and select Hidden Column. 

 

 

 

 

 

 

O
ra

cl
e 

In
te

rn
al

 &
 O

ra
cl

e 
Ac

ad
em

y 
U

se
 O

nl
y



 

Copyright © 2019, Oracle and/or its affiliates. All rights reserved. 

142  Practices for Lesson 5: Creating Interactive Reports 

2. Remove the Highlight option from the Actions menu. 

a. On the Rendering tab (left pane), expand Regions > Content Body > Employee 

Commission and select Attributes. 

  

b. In the Property Editor (right pane), scroll down to the Actions Menu section. 

Alternatively, enter actions in the Filter field. 

  

  

O
ra

cl
e 

In
te

rn
al

 &
 O

ra
cl

e 
Ac

ad
em

y 
U

se
 O

nl
y



 

Copyright © 2019, Oracle and/or its affiliates. All rights reserved. 

Practices for Lesson 5: Creating Interactive Reports  143 

c. For Highlight, select No to remove it from the Actions Menu. (If you used the filter, clear 

the Filter field to redisplay all options.) 

 

d. Click the Save and Run Page. 
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The report appears. Note that Employee ID is excluded from the report. The Manager 

column displays the First Name and Last Name of the manager. 

 

Additionally, the Highlight option is removed in the Actions > Format menu. 

e. The interactive report creation is complete. Click Application 111 on the Runtime 

Developer Toolbar at the bottom of the page to return to the Application home page. 
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Practices for Lesson 6 

Overview 

In these practices, you will create a page with an interactive grid, customize it in the application, 

then convert it to an editable interactive grid, and customize it further. 
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Practice 6-1: Creating an Interactive Grid 

Overview 

In this practice, you create a report on OEHR_PRODUCT_INFORMATION for the GMT application. 

This report uses an interactive grid for end users to update the data more easily. 

Assumptions 

You have completed the previous practices.  

Note: If you have not completed the previous practices, execute the steps mentioned in the 

Catch Up section of this practice. 

Tasks 

1. On a new page in the GMT application, create an interactive grid to display columns from 

the OEHR_PRODUCT_INFORMATION table. Name the new page and report Product 

Information Details and number it page 6. 

2. Run the app and customize the report. 

a. Sort the report by Product Id. 

b. Hide the Category Id column. 

c. Break the report by Product Status. (Hint: Apply a control break.) 

d. Save the report as the Primary report. 

e. Create a Pie chart that counts the number of items in each weight class. 

f. Save your customizations as a private report named My Report. 

Catch Up 

If you have not completed Practice 2-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_admin user. 

b. Click the arrow next to SQL Workshop and select SQL Scripts. 

c. Click the Upload button. 

d. Browse and upload the sol_02_01.sql file in the 

/home/oracle/labs/solutions directory. 

e. Run the script by clicking the Run icon. 

f. Click Run Now.  

g. Make sure that the script executed successfully and the apex_dev user is created. 

 

If you haven’t completed Practice 2-3: Installing a Sample Dataset, perform the steps to 

install a sample dataset before you start with Practice 6-1. 

 

If you have not completed Practice 5-2, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_dev user. 

b. Click the arrow next to App Builder and select Import. 
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c. For Import File, click the button and browse to the sol_05_02.sql file in the 

/home/oracle/labs/solutions directory and click Next. 

d. Click Next. 

e. For Install As Application, select Reuse Application ID 111 From Export File and 
click Install Application. 

f. Click Replace Application (if prompted). 

g. Wait for the application to successfully install. 
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Practice 6-2: Using and Manipulating the Interactive Grid 

Overview 

In this practice, you convert the interactive grid to an editable interactive grid and explore the 

data entry capabilities. 

Assumptions 

You have completed the previous practices.  

Note: If you have not completed the previous practices, execute the steps mentioned in the 

Catch Up section of this practice. 

Tasks 

1. Convert the interactive grid to an editable interactive grid in Page Designer. 

2. In the app run time, customize the report further: 

 Add a blank new row to the report. 

 Duplicate the blank row. 

 Attempt to save the report. 

 Delete the blank rows. 

3. In Page Designer, lock all displayed columns but one: Product Description. (Hint: Lock a 

column by making it Display Only.) 

Catch Up 

If you have not completed Practice 2-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_admin user. 

b. Click the arrow next to SQL Workshop and select SQL Scripts. 

c. Click the Upload button. 

d. Browse and upload the sol_02_01.sql file in the 

/home/oracle/labs/solutions directory. 

e. Run the script by clicking the Run icon. 

f. Click Run Now.  

g. Make sure that the script executed successfully and the apex_dev user is created. 

 

If you haven’t completed Practice 2-3: Installing a Sample Dataset, perform the steps to 

install a sample dataset before you start with Practice 6-2. 

 

If you have not completed Practice 6-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_dev user. 

b. Click the arrow next to App Builder and select Import. 

c. For Import File, click the button and browse to the sol_06_01.sql file in the 

/home/oracle/labs/solutions directory and click Next. 
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d. Click Next. 

e. For Install As Application, select Reuse Application ID 111 From Export File and 
click Install Application. 

f. Click Replace Application (if prompted). 

g. Wait for the application to successfully install. 
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Solution 6-1: Creating an Interactive Grid 

Overview 

In this practice solution, steps are provided to create the interactive grid for the GMT application. 

Steps 

1. Create an interactive grid to display columns from the OEHR_PRODUCT_INFORMATION 

table. 

a. Navigate to the GMT application home page and click Create Page. 

 

b. Select Report. 
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c. Select Interactive Grid. 

 

d. For Page Number, enter 6. For Page Name, enter Product Information 

Details.  

 

e. Click Next. 
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f. For Navigation Preference, accept the default and click Next. 

 

g. For Source Type, select Table. 

h. For Table / View Name, click the  icon to search for a table. In the Search dialog 

box, find and select OEHR_PRODUCT_INFORMATION (table) and click Create. 

 

i. The report is created. To view the report, click the Save and Run Page. 
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Note: If prompted, enter your developer user credentials. The Interactive Grid is 

displayed. 

 

 

2. Explore the interactive grid interface. Interactive grids share many of the same features as 

interactive reports. 

a. Sort by Product Id. 

i. Place the cursor over the Product Id column heading. 

ii. On the right side of the column name, two arrow icons have now appeared. 

Click the up arrow icon (Sort Ascending). 

 

The interactive grid after sorting the Product ID column. 
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b. Hide the Category Id column. 

i. Click the column heading Category Id to open the Column Heading menu. 

ii. Click the Hide icon. 

 

The column is hidden from display. 
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c. Apply a Control Break to organize the report by Product Status. 

i. Click the column heading Product Status to open the Column Heading 

menu. 

ii. Click the Control Break icon. 

 

The Control Break is applied. A Control Break item also appears above the report 

(“Product Status”). 
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d. Save this as the new Primary report. 
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i. Click Actions > Report > Save. 

  

This is now the default report for all users. 
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e. Create a chart to see the proportion of products by weight class. 

i. Click Actions > Chart. 

  

ii. For Type, select Pie. 

iii. Update the following fields: 

 Label: Select Weight Class 

 Value: Select Weight Class 

 Aggregation: Select Count 
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iv. Click Save. The chart is displayed. 
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v. Move the mouse over different parts of the chart and the legend to see how 

the interactive grid responds. 

 

vi. When finished, click the Grid icon  near the Actions menu button. 

 

f. Save this as a private report. 
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i. Click Actions > Report > Save As. 

ii. For Name, enter My Report and click Save. 

 

You get the message “Private report saved”. 

Note: A drop-down menu appears with a list of available reports for the 

interactive grid. 

  

iii. On the Runtime Developer toolbar at the bottom of the screen, click Edit Page 
6 to return to Page Designer. 
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Solution 6-2: Using and Manipulating the Interactive Grid 

Overview 

In this practice solution, steps are provided to convert the interactive grid for the GMT 

application to an editable interactive grid and customize it further in the application and in Page 

Designer. 

Steps 

1. Convert the interactive grid to an editable interactive grid in Page Designer and run the 

page again. 

a. Return to Page Designer and make the interactive grid region editable. 

 On the Rendering tab (left pane), under Regions > Content Body > Product 

Information Details, select Attributes. 

 

 In the Property Editor (right pane), under the Edit section, for Enabled select Yes. 
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The interactive grid is now an editable interactive grid. 

 Click the Save and Run Page. 

 

Note: If prompted, enter your developer user credentials. 

b. Note the greatly expanded toolset at the top of the interactive grid. Editable interactive grids 

enable users to add to and modify the table directly without a form. 

i. Near the Actions menu, click the Add Row button. 

 

A blank row appears. The two left-most columns of an editable interactive grid are: 

 The Selection column 

 The Actions column 

The top-most icons (located in the same row as the column headings) are for batch 

actions, such as Select All or Select None. The icons below the column heading row 

are for individual rows. 

ii. Click the Row Actions menu for the blank row. 

iii. Click Duplicate Row. 
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A second blank row appears. Note the error markings that appear. 

 

iv. Try clicking the Save button at the top of the report. You see an error. The table does 

not change until the report saves, and Application Express prevents you from saving in 

the event of an error. Click OK. 
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v. Select the check box for each blank row to select both, click the Selection Actions 

icon at the top of the column, and click Delete Rows. 

 

 

c. You want to keep most of the information in this report intact, so set columns to Display 

Only to prevent users from updating. Lock columns in the report so that only Product 

Description is editable. 

i. Click Edit Page 6 on the Runtime Developer toolbar at the bottom of the page to return 

to Page Designer. 

 

ii. On the Rendering tab, expand the Columns node. 

iii. Ctrl-click the following items: (Do NOT select all columns.) 

 PRODUCT_ID 

 PRODUCT_NAME 

 CATEGORY_ID 

 WEIGHT_CLASS 

 WARRANTY_PERIOD 

 SUPPLIER_ID 

 PRODUCT_STATUS 

 LIST_PRICE 

 MIN_PRICE 

 CATALOG_URL 
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iv. In the Property Editor (right pane), under the Identification section, for Type select 

Display Only. 

 

v. Click the Save and Run Page. 

  

d. The Product Description column is now the only editable column in the report. Try double-

clicking within the Product Description column to see what happens and then click other 

entries in different columns too.  
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e. The interactive grid is complete. Click Application 111 on the Runtime Developer toolbar to 

return to the Application home page. 
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Practices for Lesson 7: Overview 

Overview 

In these practices, you work with pages and regions and update the Global Page for the 

application. 
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Practice 7-1: Creating and Modifying Pages and Regions 

Overview 

In this practice, you create a report region, create a subregion, and modify the attributes of the 

report. You create a sidebar region and add footer to the Customer Details page. 

Assumptions 

You have completed the previous practices. 

Note: If you haven’t completed the previous practices, execute the steps mentioned in the 

Catch Up section of this practice.  

Tasks 

1. Create a blank page called Products with a region called Products List. Set the page 

number as 7. Create a new tab called Products by using the existing tab set for this page. 

2. Create a new report region called Products List on the Products page. Use a Classic 

Report and display all the rows in the OEHR_PRODUCTS_INFORMATION table. Run the 

report after it is created. 

3. Modify the report so that it is a subregion in the Products region and displays only the 

Product ID, Product Name, Category ID, Product Status, and List Price 

columns in the report. Also, you want to display only 10 rows at a time and show the 

pagination in a select list. After you have performed these tasks, run the report. 

4. Create a Hint sidebar region on the right side of the Customer Details page that includes 

the following HTML code (located in /home/oracle/labs/labs/lab_07_01_01.txt): 

Use this page to enter and <br> maintain customer information. 

5. Add a footer to the Customer Details region on the Customer Details page so that the 

following message (located in /home/oracle/labs/labs/lab_07_01_02.txt) 

appears at the bottom of the region when a user enters this page: 

<i>The record created or modified in this form is reflected in 

the Customer Report.</i> 

Catch Up 

If you haven’t completed Practice 2-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_admin user. 

b. Click the arrow next to SQL Workshop and select SQL Scripts. 

c. Click the Upload > button. 

d. Browse and upload the sol_02_01.sql file in the 

/home/oracle/labs/solutions directory. 

e. Run the script by clicking the Run icon. 

f. Click Run Now. 

g. Make sure that the script executed successfully and the apex_dev user is created. 
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If you haven’t completed Practice 2-3: Installing a Sample Dataset, perform the steps to 

install a sample dataset before you start with Practice 7-1. 

 

If you haven’t completed Practice 6-2, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_dev user. 

b. Click the arrow next to Application Builder and select Import. 

c. Click the Browse button. 

d. Browse and open the sol_06_02.sql file in the /home/oracle/labs/solutions 

directory and click Next >. 

e. Click Next >. 

f. Select Reuse Application ID 111 From Export File for the Install As Application 
option and click Install Application. 

g. Click Replace Application (if prompted). 

h. Wait for the application to successfully install. 
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Practice 7-2: Working with Global Pages 

Overview 

In this practice, you view the Global page in your application and then add a Static HTML 

subregion to the Global Desktop Page. 

Assumptions 

You have completed the previous practices.  

Note: If you haven’t completed the previous practices, execute the steps mentioned in the 

Catch Up section of this practice. 

Tasks 

1. Navigate to Global desktop page in the GlobalMart Management Tool application and 

review it in Application Properties. 

2. Add a Static HTML region to the Global Desktop page. Call the region as In the News on 

the Global page with the following code (located in 

/home/oracle/labs/labs/lab_07_02.txt): 

<html><body> 

<p><strong>News and Events</strong></p> 

<p>Visit us at <a href="http://www.oracle.com"> 

www.oracle.com</a></p> 

</body></html> 

Catch Up 

If you haven’t completed Practice 2-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_admin user. 

b. Click the arrow next to SQL Workshop and select SQL Scripts. 

c. Click the Upload > button. 

d. Browse and upload the sol_02_01.sql file in the 

/home/oracle/labs/solutions directory. 

e. Run the script by clicking the Run icon. 

f. Click Run Now. 

g. Make sure that the script executed successfully and the apex_dev user is created. 

 

If you haven’t completed Practice 2-3: Installing a Sample Dataset, perform the steps to 

install a sample dataset before you start with Practice 7-2. 

 

If you haven’t completed Practice 7-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_dev user. 

b. Click the arrow next to Application Builder and select Import. 

c. Click the Browse button. 
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d. Browse and open the sol_07_01.sql file in the /home/oracle/labs/solutions 

directory and click Next >. 

e. Click Next >. 

f. Select Reuse Application ID 111 From Export File for the Install As Application option 
and click Install Application. 

g. Click Replace Application (if prompted). 

h. Wait for the application to successfully install. 
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Solution 7-1: Creating and Modifying Pages and Regions 

Overview 

In this practice solution, steps are provided for creating and modifying pages and regions in the 

GMT application. 

Steps 

1. Create a blank page called Products with a region called Products List. Set the page 

number as 7. Create a new tab called Products by using the existing tab set for this page. 

a. On the GMT Application Home page, click Create Page. 
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b. Select Blank Page. 

 

c. For Page Attributes: 

 Page Number: Enter 7. 

 Name: Enter Products. 

 Optional Static Content Regions: Expand and enter Products for Region 1. 

 

d. Click Next >. 
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e. For Navigation Menu: 

 Navigation Preference: Select Create a new navigation menu entry. 

 New Navigation Menu Entry: Ensure that the text field is set to Products. 

 Parent Navigation Menu Entry: Ensure that - No parent selected – is selected. 

 

f. Click Next >. 
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g. Click Finish. 

 

 

2. Create a new report region called Products List on the Products page. Use a Classic 

Report and display all the rows in the OEHR_PRODUCTS_INFORMATION table. Run the 

report after it is created. 

a. In the Gallery at the bottom of the central pane in Page Designer, select the Regions 
tab and find Classic Report. 
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b. Right-click Classic Report to display the context menu and select Add To > Content 
Body > Products > After. 

 

c. Edit the appropriate attributes in the Property Editor (the right pane): 

 Identification > Title: Enter Products List. 

 Source > Type: Select Table/View (if not selected by default). O
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 Source > Table Name: Select OEHR_PRODUCT_INFORMATION by clicking the 

 icon. 

 

d. Click Save. 

e. Test your page by clicking Save and Run Page. 
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f. The report is displayed. (Note: If you are prompted to sign in, the Home page is 
displayed. Click the Products tab to view the report.) Click the Edit Page 7 link on the 
Runtime Developer toolbar. 
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3. Modify the Products List report so that it becomes a subregion under the Products region 

and only displays Product ID, Product Name, Category ID, Product Status, and 

List Price columns in the report. Also, you want to display only 10 rows at a time and 

show the pagination in a select list. After you have performed these tasks, run the report. 

a. On the Rendering tab, expand Regions > Content Body and select Product List. 

 

b. In the Property Editor (the right pane), Layout > Parent Region, select Products. 
Notice that the Products List region becomes a subregion of Products. Alternatively, 
you can use the drag-and-drop feature. 
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c. On the Rendering tab, expand Regions > Content Body > Products > Sub 

Regions > Products List > Columns > and select PRODUCT_DESCRIPTION. 

 

d. In the Property Editor (the right pane), Identification > Type, select Hidden Column. 
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e. On the Rendering tab, press Ctrl and select the following columns: 

 WEIGHT_CLASS 

 WARRANTY_PERIOD 

 SUPPLIER_ID 

 MIN_PRICE 

 CATALOG_URL 

 

f. In the Property Editor (the right pane), Identification > Type, select Hidden Column. 
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g. On the Rendering tab, expand Regions > Content Body > Products > Sub 
Regions > Products List > and select Attributes. 

 

h. In the Property Editor (the right pane):  

1) Layout > Number of Rows: Enter 10. 

2) Pagination > Type: Select Row Ranges 1-15 16-30 in select list (with 
pagination) from the drop-down list. 
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i. Click Save and then Save and Run Page. 

 

j. Notice that the Products List region is now displayed in the Products parent region, 
and only the columns that you specified appear. Also, notice the pagination is now in a 
select list. 

 
Click the Application 111 link on the Runtime Developer toolbar. 

 

 

4. Create a page (Page 8 – Update Customer) and modify it to create a Hint sidebar region 

on the right side of the Update Customer page that includes the following HTML code 

(located in /home/oracle/labs/labs/lab_07_01_01.txt): 

Use this page to enter and <br> maintain customer information. 
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a. You will first create a Form Page. Go to your Application 111 and click Create Page. 
 

 

b. Click Form and click Next >.  

Note: In this example, we create a simple Form and add a Hint sidebar region. In the 
lesson titled “Managing Forms,” you will be learning more about creating different types 
of Forms. 
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c. Click Form. 

   

d. In the Create Form on a Table page, enter the following details: 

 Page Number: Enter 8 

 Page Name: Update Customers 

 Branch here on Submit: Select 4 

 Cancel and Go to Page: Select 4 

 Click Next>. 
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e. Keep the default navigation settings and click Next>. 

 

f. To define the table source, select the following: 

 Source Type: Select Table 

 Table/View Name: Select OEHR_CUSTOMERS (table) 

 

 Click Next>.  
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 Select Select Primary Key Column(s) for Primary Key Type. For Primary Key 

Column, select CUSTOMER_ID (Number).  

 

 Click Create.   

g. The Update Customers form page is created and opens in Page Designer view. In the 
bottom of the central pane of Page Designer, click the Regions tab. 

h. Right-click Content Body and select Create Region. 

 

i. In the Property Editor (the right pane): 

 Identification > Title: Enter Hint. 

 Identification > Type: Select Static Content (if not selected by default). 

 Source > Text: Enter the following (located in 

/home/oracle/labs/labs/lab_07_01_01.txt) in the Text field. 
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Use this page to enter and <br> maintain customer information. 

 

j. Click Save and then Save and Run Page. 

 

k. Note that although the Hint region is created, it is not displayed as a sidebar region on 
the right side of the page. To display it as a side bar region, you need to change the 
page template so that a sidebar is provided. Click the Edit Page 8 link on the Runtime 
Developer toolbar. 

 

 

O
ra

cl
e 

In
te

rn
al

 &
 O

ra
cl

e 
Ac

ad
em

y 
U

se
 O

nl
y



 

Copyright © 2019, Oracle and/or its affiliates. All rights reserved. 

192  Practices for Lesson 7: Working with Pages and Regions 

l. Select Create Form, and then in the Property Editor, Identification > Title: Enter 

Update Customers. 

 

m. Drag the Hint region to the right of the Update Customers region. 

 

O
ra

cl
e 

In
te

rn
al

 &
 O

ra
cl

e 
Ac

ad
em

y 
U

se
 O

nl
y



 

Copyright © 2019, Oracle and/or its affiliates. All rights reserved. 

Practices for Lesson 7: Working with Pages and Regions  193 

 

n. Run the page again and you see the Hint region on the right. Click Save. Run the page 
by clicking Save and Run Page. 

 

o. Modify the Hint region such that it takes only two column span. Click the Edit Page 8 
link on the Runtime Developer toolbar. 
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p. Ensure that the Hint region is selected either on the Rendering tab or on the Layout 
tab (Central pane). In the Property Editor, under Layout > Column Span, select 2. 

 

q. Click Save and then Save and Run Page. 

 

r. Note that the Hint region now displays on the right side of the page, occupying lesser 
space than before. Click the Edit Page 8 link on the Runtime Developer toolbar. 
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5. Add a footer to the Update Customer region on the Update Customer page so that the 

following message (located in /home/oracle/labs/labs/lab_07_01_02.txt) 

appears at the bottom of the region when a user enters this page: 

<i>The record created or modified in this form is reflected in 

the Customer Report.</i> 

a. On the Rendering tab, select Regions > Content Body > Update Customers. 

b. In the Property Editor (the right pane): Copy the footer text (located in the 

/home/oracle/labs/labs/lab_07_01_02.txt) and paste it into the Header 

Footer > Footer Text. 

<i>The record created or modified in this form is reflected in 

the Customer Report.</i> 

 

c. Click Save and then Save and Run Page. 
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d. The footer text is displayed. Click the Application 111 link on the Runtime Developer 
toolbar. 
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Solution 7-2: Working with Global Pages 

Overview 

In this practice solution, steps are provided to update the Global page in the GMT application. 

Steps 

1. View the 0 – Global Page – Desktop page in the GlobalMart Management Tool application 

and review it in Application Properties. 

a. Navigate to the GlobalMart Management Tool application home page and click 0-
Global Page. 

 

b. The Global Page - Desktop opens in Page Designer. 

 

2. Add a Static HTML region to the Global Desktop page. Name the region as In the News on 

the Global page with the following code (located in 

/home/oracle/labs/labs/lab_07_02.txt): 

a. On the Rendering tab, right-click the Regions and click Create Region. 

O
ra

cl
e 

In
te

rn
al

 &
 O

ra
cl

e 
Ac

ad
em

y 
U

se
 O

nl
y



 

Copyright © 2019, Oracle and/or its affiliates. All rights reserved. 

198  Practices for Lesson 7: Working with Pages and Regions 

 

b. In the Property Editor (the right pane): 

1) Identification > Title: Enter In the News. 

2) Source > Text: (Copy content from the 

/home/oracle/labs/labs/lab_07_02.txt.) 

<html><body> 

<p><strong>News and Events</strong></p> 

<p>Visit us at <a href="http://www.oracle.com"> 

www.oracle.com</a></p> 

</body></html> 

3) Layout > Position: Select Before Content Body
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4) Click Save. 

 

c. Click the Application 111 breadcrumb. 

 

d. Click Run Application. 
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The home page is displayed with the In the News region.  
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e. Click the Customers tab. You will notice that the In the News region appears on this 
page too. 

 

f. Click the Products tab. The region appears here as well. 

 

g. Click the Application 111 link on the Runtime Developer toolbar. 
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Practices for Lesson 8: Overview 

Overview 

In these practices, you create and use different types of forms for GMT application, namely, 

Form on a Table, Report with List View on a Table, and Master Detail Form – Side By Side, 

Drill-down, and Stacked.  

O
ra

cl
e 

In
te

rn
al

 &
 O

ra
cl

e 
Ac

ad
em

y 
U

se
 O

nl
y



 

Copyright © 2019, Oracle and/or its affiliates. All rights reserved. 

Practices for Lesson 8: Creating and Managing Forms  205 

Practice 8-1: Creating a Form  

Overview 

In this practice, you create a form and then link the form to the Customers report that was 

created previously. 

Assumptions 

You have completed the previous practices.  

Note: If you haven’t completed the previous practices, execute the steps mentioned in the 

Catch Up section of this practice. 

Tasks 

1. Create a form based on the CUSTOMERS table. Enter 9 as the page number. The form page 

and region should be titled Customer Details and contain the customer’s First Name, Last 

Name, Email, and Manager ID fields. The following are the other requirements: 

 Ensure that the primary key has the value CUSTOMER_ID. 

 The Create and Cancel buttons are required. 

 Branch to the Customers page for both: “After Page Submit and Processing” and 
“When Cancel Button Pressed.” 

 Run the form for verification. 

2. Link the form to the report. When the Edit icon in the report is clicked, the user should be 

redirected to the form and the details populated in the form. 

Catch Up 

If you haven’t completed Practice 2-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_admin user. 

b. Click the arrow next to SQL Workshop and select SQL Scripts. 

c. Click the Upload > button. 

d. Browse and upload the sol_02_01.sql file in the 

/home/oracle/labs/solutions directory. 

e. Run the script by clicking the Run icon. 

f. Click Run Now. 

g. Make sure that the script executed successfully and the apex_dev user is created. 

 

If you haven’t completed Practice 2-3: Installing a Sample Dataset, perform the steps to 

install a sample dataset before you start with Practice 8-1. 

 

If you haven’t completed Practice 7-2, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_dev user. 

b. Click the arrow next to Application Builder and select Import. 
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c. Click the Browse button. 

d. Browse and open the sol_07_02.sql file in the /home/oracle/labs/solutions 

directory and click Next >. 

e. Click Next >. 

f. Select Reuse Application ID 111 From Export File for the Install As Application 
option and click Install Application. 

g. Click Replace Application (if prompted). 

h. Wait for the application to successfully install. 
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Practice 8-2: Creating a List View with Form 

Overview 

In this practice, you create a list view with form. 

Assumptions 

You have completed the previous practices.  

Note: If you haven’t completed the previous practices, execute the steps mentioned in the 

Catch Up section of this practice. 

Tasks 

1. Create a list view with a form based on the Customers table. Enter 10 as the report page 

number and 11 as the form page number. The report page should be titled Customers List 

View and contain the Customer’s First Name, Last Name, Email, and Manager ID fields. 

The form page should be titled Form on Customers and contain the Customer’s First 

Name, Last Name, Email, and Manager ID fields. The following are the other requirements: 

 Ensure that the primary key has the value Customer_ID. 

 The Create, Cancel, Delete, and Apply Changes buttons are required. 

 Run the form for verification. 

Catch Up 

If you haven’t completed Practice 2-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_admin user. 

b. Click the arrow next to SQL Workshop and select SQL Scripts. 

c. Click the Upload > button. 

d. Browse and upload the sol_02_01.sql file in the 

/home/oracle/labs/solutions directory. 

e. Run the script by clicking the Run icon. 

f. Click Run Now. 

g. Make sure that the script executed successfully and the apex_dev user is created. 

 

If you haven’t completed Practice 2-3: Installing a Sample Dataset, perform the steps to 

install a sample dataset before you start with Practice 8-2. 

 

If you haven’t completed Practice 8-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_dev user. 

b. Click the arrow next to Application Builder and select Import. 

c. Click the Browse button. 

d. Browse and open the sol_08_01.sql file in the /home/oracle/labs/solutions 

directory and click Next >. 
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e. Click Next >. 
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f. Select Reuse Application ID 111 From Export File for the Install As Application 
option and click Install Application. 

g. Click Replace Application (if prompted). 

h. Wait for the application to successfully install. 
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Practice 8-3: Creating a Master Detail Form (Side By Side) 

Overview 

In this practice, you create a form that is based on two tables (Master table and Detail table) and 

make some modifications to it. 

Assumptions 

You have completed the previous practices.  

Note: If you haven’t completed the previous practices, execute the steps mentioned in the 

Catch Up section of this practice. 

Tasks 

1. On a new page called Master Detail Form, create a Master Detail Form (List of Orders 

page 12) based on the ORDERS and ORDER_ITEMS tables.  

Note: Two additional pages are created while creating the Master Detail Form (Side by 

Side). You cannot choose the page numbers of these two pages. In this activity, the page 

numbers are 13 (Oehr Orders) and 14 (Oehr Order Items). The page numbers 

may vary with different application IDs. 

 Include a report page called List of Orders on the master table. 

 Display the master table and detail table forms on a single page. 

 Exclude the ORDER_ID column in the ORDER_ITEMS table. 

 Include navigation based on the ORDER_ID column. 

2. On the Master Detail Form page, change the region name for the master region to Order 

Master and change the region name for the detail region to Order Details. 

3. On the Master Detail page, move the Order Status item to appear before the Customer ID 

in the Order Master region. 

4. On the List of Orders (master report) page, do not show the PROMOTION_ID column. 

Change the heading of Sales Rep ID to Sales Rep. 

Catch Up 

If you haven’t completed Practice 2-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_admin user. 

b. Click the arrow next to SQL Workshop and select SQL Scripts. 
c. Click the Upload > button. 

d. Browse and upload the sol_02_01.sql file in the 

/home/oracle/labs/solutions directory. 

e. Run the script by clicking the Run icon. 
f. Click Run Now. 
g. Make sure that the script executed successfully and the apex_dev user is created. 
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If you haven’t completed Practice 2-3: Installing a Sample Dataset, perform the steps to 

install a sample dataset before you start with Practice 8-3. 

 

If you haven’t completed Practice 8-2, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_dev user. 

b. Click the arrow next to Application Builder and select Import. 

c. Click the Browse button. 

d. Browse and open the sol_08_02.sql file in the 

/home/oracle/labs/solutions directory, and click Next >. 

e. Click Next >. 

f. Select Reuse Application ID 111 From Export File for the Install As Application 
option and click Install Application. 

g. Click Replace Application (if prompted). 

h. Wait for the application to successfully install. 
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Practice 8-4: Creating a Master Detail Form (Stacked) 

Overview 

In this practice, you create a form that is based on two tables (Master table and Detail table). 

Assumptions 

You have completed the previous practices.  

Note: If you haven’t completed the previous practices, execute the steps mentioned in the 

Catch Up section of this practice. 

Tasks 

1. On a new page called Master Detail Form, create a Master Detail Form based on the 

ORDERS and ORDER_ITEMS tables and specify the page number as 15. 

 Include a report page called Orders List on the master table. 

 Display the master table and detail table forms on a single page. 

 Include navigation based on the ORDER_ID column. 

Catch Up 

If you haven’t completed Practice 2-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_admin user. 

b. Click the arrow next to SQL Workshop and select SQL Scripts. 

c. Click the Upload > button. 

d. Browse and upload the sol_02_01.sql file in the /home/oracle/labs/solutions 

directory. 

e. Run the script by clicking the Run icon. 

f. Click Run Now. 

g. Make sure that the script executed successfully and the apex_dev user is created. 

 

If you haven’t completed Practice 2-3: Installing a Sample Dataset, perform the steps to 

install a sample dataset before you start with Practice 8-4. 
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If you haven’t completed Practice 8-3, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_dev user. 

b. Click the arrow next to Application Builder and select Import. 

c. Click the Browse button. 

d. Browse and open the sol_08_03.sql file in the /home/oracle/labs/solutions 

directory and click Next >. 

e. Click Next >. 

f. Select Reuse Application ID 111 From Export File for the Install As Application option 
and click Install Application. 

g. Click Replace Application (if prompted).  

h. Wait for the application to successfully install. 
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Practice 8-5: Creating a Master Detail Form (Drill-Down) 

Overview 

In this practice, you create a form that is based on two tables (Master table and Detail table). 

Assumptions 

You have completed the previous practices.  

Note: If you haven’t completed the previous practices, execute the steps mentioned in the 

Catch Up section of this practice. 

Tasks 

1. On a new page called Master Detail Form, create a Master Detail Form based on the 

CUSTOMERS and ORDERS tables and specify the page numbers as 20 and 21, respectively. 

 Include a report page called Customer Master Information on the master table. 

 Display the master table and detail table forms on a single page. 

Catch Up 

If you haven’t completed Practice 2-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_admin user. 

b. Click the arrow next to SQL Workshop and select SQL Scripts. 

c. Click the Upload > button. 

d. Browse and upload the sol_02_01.sql file in the /home/oracle/labs/solutions 

directory. 

e. Run the script by clicking the Run icon. 

f. Click Run Now. 

g. Make sure that the script executed successfully and the apex_dev user is created. 

 

If you haven’t completed Practice 2-3: Installing a Sample Dataset, perform the steps to 

install a sample dataset before you start with Practice 8-5. 
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If you haven’t completed Practice 8-4, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_dev user. 

b. Click the arrow next to Application Builder and select Import. 

c. Click the Browse button. 

d. Browse and open the sol_08_04.sql file in the 

/home/oracle/labs/solutions directory and click Next >. 

e. Click Next >. 

f. Select Reuse Application ID 111 From Export File for the Install As Application 
option and click Install Application. 

g. Click Replace Application (if prompted).  

h. Wait for the application to successfully install. 
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Solution 8-1: Creating a Form  

Overview 

In this practice solution, steps are provided for creating a form for the GMT application. 

Steps 

1. Create a form based on the OEHR_CUSTOMERS table. Enter 9 as the page number. The form 

page and region should be titled Customer Details and contain the customer’s First Name, 

Last Name, Email, and Manager ID fields. The following are the other requirements: 

 Ensure that the primary key has the value CUSTOMER_ID. 

 The Create and Cancel buttons are required. 

 Branch to the Customers page for both: “After Page Submit and Processing” and 
“When Cancel Button Pressed.” 

 Run the form for verification. 

a. On the GMT Application Home page, click Create Page. 
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b. Select the Form option. 

 

c. Click Next >.  

d. Select Form. 
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e. Click Next. 

f. Enter the Page Attributes: 

 Page Number: Enter  9 

 Page Name: Enter Customer Details 

 Branch Here on Submit: Select 4 (Customer Report) page. 

 Cancel and Go To Page: Select 4 (Customer Report) page. 

      

 

g. Click Next >. 

h. Accept the default for Navigation Menu and click Next >.

 

i. For Data Source: 

 Source Type: Select Table 
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 Table/View Name: Click the   icon and select OEHR_CUSTOMERS (table) 

from the drop-down list. 

 

j. Click Next >. 

k. For Form Attributes: 

 Select Columns: Select CUST_FIRST_NAME, CUST_LAST_NAME, CUST_EMAIL, 

and ACCOUNT_MGR_ID. Ensure that these columns are in the right column. Use the 

right arrow (>) and left arrow (<) to move the columns. 

 Primary Key Type: Select Select Primary Key Column(s).  

 Primary Key Column: Select CUSTOMER_ID (Number) from the drop-down list. 
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l. Click Create. The Customer Details form page opens in Page Designer view. 

m. Select Customer Details > Regions > Content Body > Create Form and in the 

Property Editor Identification > Title > Enter Customer Details. 

 

 

n. Click the Save and Run Page icon. 
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o. If the sign in page appears, enter your credentials and click Sign in. 

 

p. Review the form. Click Cancel and the Customer Report page appears. 
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 To return to the application home page, click the Application 111 link on the Runtime 
Developer toolbar. 

 

 

2. Link the Customers report (page 4) that was created previously to the newly created 

Customer Details form. When the Edit icon in the report is clicked, the user should be 

redirected to the form and the details populated in the form. After you create the link, run 

the report and verify the changes. 

a. On the GMT Application Home page, click 4 - Customers. The Customers page opens 
in Page Designer. 
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b. In the Rendering tab, select Regions > Content Body and select Attributes. 

 

c. In the Property Editor (the right pane): 

 Link > Link Column: Select Link to Custom Target 

 

 Link > Target: Click No Link Defined. The Link Builder –Target page is 

displayed. 
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 Target > Page: Click  icon and select 9 - Customer Details from the drop-

down list 

 Set items > Name: Click  icon and select P9_CUSTOMER_ID link from the 

Name drop-down list 

 Set items > Value: Click  icon and select CUSTOMER_ID link from the 

value drop-down list 
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 Click OK. 

 

d. Click Save and then Save and Run Page. 
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e. The Customers report page opens. Click the Edit icon for any one of the rows. 

 

f. Note that you are redirected to the Customer Details form and that the values are 
automatically populated in the form. You can make changes and delete the active 
record by using this form. To return to the application home page, click the Application 
111 link on the Runtime Developer toolbar. 
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Solution 8-2: Creating a List View with Form 

Overview 

In this practice solution, steps are provided for creating a list view with form for the GMT 

application. 

Steps 

1. Create a list view with a form based on the Customers table. Enter 10 as the report page 

number and 11 as the form page number. The form page should be titled Customers List 

View and contain the Customer’s First Name, Last Name, Email, and Manager ID fields. 

The report page should be titled Form on Customers and contain the Customer’s First 

Name, Last Name, Email, and Manager ID fields. The following are the other requirements: 

 Ensure that the primary key has the value Customer_ID. 

 The Create, Cancel, Delete, and Apply Changes buttons are required. 

 Run the form for verification. 

a. On the GMT Application Home page, click Create Page. 
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b. Select the Form option. 

 

c. Click Next >. 

d. Select List View with Form. 

 

e. For List View Page: 

 Report Page Number: Enter 10 

 Report Page Name: Enter Customers List View 

 Form Page Number: Enter 11 
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 Form Page Name: Enter Form on Customers 

 

f. Click Next >. 
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g. For Navigation Menu: 

 Navigation Preference: Select the Create a new navigation menu entry. 

 New Navigation Menu Entry: Ensure that the text field is set to Customer List 
View.  

 Parent Navigation Menu Entry: Select - No parent selected – (if not selected by 
default) 
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h. For Data Source: 

 Table/View Owner: Selected by default OEHR. 

 Table/View Name: Select OEHR_CUSTOMERS (table) from the drop-down list. 

 Select Columns to be shown in the report: Select CUSTOMER_ID, 

CUST_FIRST_NAME, CUST_LAST_NAME, PHONE_NUMBER, CUST_EMAIL, and 

ACCOUNT_MGR_ID.  Ensure these columns are in the right column. Use the right 

arrow (>) and left arrow (<) to move the columns. 

 

i. Click Next >. 

j. On the Form page: 

 Select Column(s) to be included in Form: Ensure that these columns are in the 

right column:  CUSTOMER_ID, CUST_FIRST_NAME, CUST_LAST_NAME, 

PHONE_NUMBER, CUST_EMAIL, and ACCOUNT_MGR_ID.  

 Primary Key Column 1: Select CUSTOMER_ID (Number) from the drop-down 

list. 
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k. Click Create. 

 

l. Click Save and Run Page. 

 

m. If the Sign in page appears, enter your credentials and click Sign in. 
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n. Review the form. Click on any list view entry. It opens the corresponding Form on 
Customers. 

  

 

o. To return to the application home page, click the Application 111 link on the Runtime 
Developer toolbar. 
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Solution 8-3: Creating a Master Detail Form (Side by Side) 

Overview 

In this practice solution, steps are provided for creating a Master Detail (Side by Side) Form for 

the GMT application. 

Steps 

1. On a new page called Master Detail Form, create a Master Detail Form (List of Orders 

page 12) based on the ORDERS and ORDER_ITEMS tables.  

Note: Two additional pages are created while creating the Master Detail Form (Side by 

Side). You cannot choose the page numbers of these two pages. In this activity, the page 

numbers are 13 (Oehr Orders) and 14 (Oehr Order Items). The page numbers 

may vary with different application IDs. 

 Include a report page called List of Orders on the master table. 

 Display the master table and detail table forms on a single page. 

 Exclude the ORDER_ID column in the ORDER_ITEMS table. 

 Include navigation based on the ORDER_ID column. 

a. On the GMT Application Home page, click Create Page. 
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b. Select Master Detail. The Create Master Detail page is displayed. 

 

c. Click Side by Side. 

 

d. Enter the Page Attributes and click Next >: 

 Starting Page Number: Enter 12 

 Master Page Detail Name: Enter List of Orders. 

 

e. Accept the default for Navigation Menu and click Next >. 
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f. For Master Detail Source:   

 Table/View Owner: OEHR. 

 Master Table: Select OEHR_ORDERS(table) from the drop-down list. 

 Primary Display Column: Select ORDER_DATE(Timestamp(6)With Local 

Time Zone) from the drop-down list. 

 Secondary Display Column: Select ORDER_MODE (varchar 2) from the 

drop-down list. 

 Detail Table: Select OEHR_ORDER_ITEMS from drop-down list. 

g. Click Create. 

 

 

h. The Master Detail Side by Side page is created. Click Save and Run Page, to view the 
Master Detail Form.  

 

i. The Master detail Form is displayed. Select any order. The order details are displayed 
side by side. Review the information. Click Edit Page 12 on the Runtime Developer 
toolbar. 
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2. On the Master Detail Form page, change the region name for the master region to Order 

Master and change the region name for the detail region to Order Details. 

a. Select Regions > Content Body > Oehr ORDERS.  

 

b. Edit the appropriate attributes in the Property Editor (the right pane): 

Identification > Title: Change from Oehr Orders to Order Master. 
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c. Select Regions > Content Body > Oehr ORDER_ITEMS.  

 

d. Edit the appropriate attributes in the Property Editor (the right pane): 

Identification > Title: Change from Oehr Order items to Order Details. 

 

 

3. On the Master Detail page, move the Order Status (under Order Master > Columns > 

Order Status) item to appear before the Customer ID in the Order Master region. 

a. You can reorder items very easily by dragging and dropping them. Drag 

ORDER_STATUS to above CUSTOMER_ID. 
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b. Verify that the item is moved. Click Save and then Save and Run Page. 
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c. Review the information. Click Edit Page 12 on the Runtime Developer toolbar. 
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4. On the List of Orders (master report) page, do not show the PROMOTION_ID column. 

Change the heading of Sales Rep ID to Sales Rep. 

a. Select Regions > Content Body > Order Master > Columns > PROMOTION_ID. 
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b. In the Property Editor (the right pane), under Identification > Type, select Hidden 
Column. 

 

O
ra

cl
e 

In
te

rn
al

 &
 O

ra
cl

e 
Ac

ad
em

y 
U

se
 O

nl
y



 

Copyright © 2019, Oracle and/or its affiliates. All rights reserved. 

Practices for Lesson 8: Creating and Managing Forms  243 

c. Select Regions > Content Body > Order Master > Columns > SALES_REP_ID. 

 

d. In the Property Editor (the right pane): Heading > Heading, change the heading to 

Sales Rep.  
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e. Click Save and then Save and Run Page. 
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f. Review the report. Note that PROMOTION_ID is no longer shown and the heading for 

Sales Rep ID has changed to Sales Rep. Click the Application 111 link on the 
Runtime Developer toolbar. 

 

 

O
ra

cl
e 

In
te

rn
al

 &
 O

ra
cl

e 
Ac

ad
em

y 
U

se
 O

nl
y



 

Copyright © 2019, Oracle and/or its affiliates. All rights reserved. 

246  Practices for Lesson 8: Creating and Managing Forms 

Solution 8-4: Creating a Master Detail Form (Stacked) 

Overview 

In this practice solution, steps are provided for creating a Master Detail (Stacked) Form for the 

GMT application. 

Steps 

1. On a new page called Master Detail, create a Master Detail (Stacked) Form based on the 

ORDERS and ORDER_ITEMS tables. 

 Include a report page called Orders List on the master table. 

 Display the master table and detail table forms on a single page. 

 Include navigation based on the ORDER_ID column. 

a. On the GMT Application Home page, click Create Page. 

 

b. Select Master Detail. The Create Master Detail page is displayed. 
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c. Click Stacked. 

 

d. Enter the Page Attributes: 

 Page Number: Enter 15 

 Page Name: Enter Orders List

 

e. Click Next >. 

f. Accept the default for Navigation Menu and click Next >. 
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g. For Master Source, enter the following and click Next >:   

 Master Region Title: Enter Orders List 

 Table/View Owner: Selected by default OEHR. 

 Table / View Name: Click  icon and select OEHR_ORDERS(table) from the 

list. 
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 Primary Key Column: Select ORDER_ID (Number) from the drop-down list. 

 

h. For Detail Source: 

 Detail Region Title: Enter Item Details 

 Show only Related Tables: Ensure Yes is selected. 

 Table/ View Name: Click  icon and select OEHR_ORDER_ITEMS. 

 Primary Key Column: Select ORDER_ITEM_ID (Number) from the drop-down 

list. 

 Master Detail Foreign Key: Select ORDER_ID -> ORDER_ID from the drop-

down list. 
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i. Click Create. 

 

j. The Master Detail Stacked page is created. Click Save and Run Page, to view the 
Master Detail Form. 
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k. The Master detail Form is displayed. Review the information. Click Application 111 on 
the Runtime Developer toolbar. 
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Solution 8-5: Creating a Master Detail Form (Drill Down) 

Overview 

In this practice solution, steps are provided for creating a Master Detail (Drill Down) Form for the 

GMT application. 

Steps 

1. On a new page called Master Detail, create a Master Detail (Drill Down) Form based on the 

OEHR_CUSTOMER and OEHR_ORDERS tables. 

 Include a report page called Customer Master Information on the master table. 

 Include navigation based on the CUST_FIRST_NAME column. 

a. On the GMT Application Home page, click Create Page. 

 

b. Select Master Detail. The Create Master Detail page is displayed. 
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c. Click Drill Down. 
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d. Define the Page Attributes and click Next >: 

 Master Page Number: Enter 16 

 Master Page Name: Enter Customer Master Information 

 Detail Page Number: Enter 17 

 Detail Page Name: Enter Customer Order History 

 

e. Accept the default for Navigation Menu and click Next >. 

 

f. For Master Source:   

 Table/View Owner: Selected by default OEHR. 

 Table / View Name: Click   icon and select OEHR_CUSTOMERS(table) from 

the list.  

 Primary Key Column: Select CUSTOMER_ID (Number) from the drop-down 

list. 

 Form navigation Order: Select CUST_FIRST_NAME (Varchar2) from the 

drop-down list. 
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g. Click Next >. 

 

h. For Detail Source: 

 Table/ View Name: Click  icon and select OEHR_ORDERS. 

 Primary Key Column: Select ORDER_ID (Number) from the drop-down list. 

 Primary Key Column 2: Select CUSTOMER_ID (Number) from the drop-down 

list. 

 Master Detail Foreign Key: Select CUSTOMER_ID -> CUSTOMER_ID from the 

drop-down list. 
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i. Click Create. 

 

j. The Master Detail Drill Down page is created. Click Save and then Save and Run 
Page, to view the Master Detail Form. 

 O
ra

cl
e 

In
te

rn
al

 &
 O

ra
cl

e 
Ac

ad
em

y 
U

se
 O

nl
y



 

Copyright © 2019, Oracle and/or its affiliates. All rights reserved. 

Practices for Lesson 8: Creating and Managing Forms  257 

k. The Master Detail Form is displayed. Review the information. 

 

l. Select a customer, for example, Eddie Bowyer (Customer Id: 159) and click the edit 
icon. 

The Customer Master information and Order Details appear.  
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Click Application 111 on the Runtime Developer toolbar. 
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Practices for Lesson 9: Overview 

Overview 

There are two practices for this lesson. In these practices, you create a variety of items and 

buttons and manipulate the way they work. 
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Practice 9-1: Adding Items and Buttons 

Overview 

In this practice, you create a Customer Feedback form that contains some items and two 

buttons. You create a button on the Customers page to link to the feedback form. 

Assumptions 

You have completed the previous practices. 

Note: If you haven’t completed the previous practices, execute the steps mentioned in the 

Catch Up section of this practice.  

Tasks 

1. Create a blank page called Customer Feedback. Enter the page number as 18. 

2. Add the following items to the form: 

Items Type 

Customer ID Text Field 

Feedback           Text Area 

Added On Date Picker 

3. Add a button on the Customers page to redirect to the Customer Feedback page. 

4. Add an Apply button on the Customer Feedback page. 

5. Add a Cancel button on the Customer Feedback page to redirect to the Customers page. 

Catch Up 

If you haven’t completed Practice 2-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_admin user. 

b. Click the arrow next to SQL Workshop and select SQL Scripts. 

c. Click the Upload > button. 

d. Browse and upload the sol_02_01.sql file in the 

/home/oracle/labs/solutions directory. 

e. Run the script by clicking the Run icon. 

f. Click Run Now. 

g. Make sure that the script executed successfully and the apex_dev user is created. 

 

If you haven’t completed Practice 2-3: Installing a Sample Dataset, perform the steps to 

install a sample dataset before you start with Practice 9-1. 

 

If you haven’t completed Practice 8-5, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_dev user. 

b. Click the arrow next to Application Builder and select Import. 
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c. Click the Browse button. 

d. Browse and open the sol_08_05.sql file in the /home/oracle/labs/solutions 

directory and click Next. 

e. Click Next >. 

f. Select Reuse Application ID 111 From Export File for the Install As Application 
option and click Install Application. 

g. Click Replace Application (if prompted). 

h. Wait for the application to successfully install. 
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Practice 9-2: Manipulating Items 

Overview 

In this practice, you add additional item types (select list and cascading LOV) and modify the 

way the fields in Customer Details forms are displayed. 

Assumptions 

You have completed the previous practices.  

Note: If you haven’t completed the previous practices, execute the steps mentioned in the 

Catch Up section of this practice. 

Tasks 

1. Modify the Account Manager item to be a select list with the following query (located in 

/home/oracle/labs/labs/lab_09_02_01.txt): 

select LAST_NAME||', '||FIRST_NAME display_value, EMPLOYEE_ID 

return_value 

from OEHR_EMPLOYEES 

where DEPARTMENT_ID=80 

order by 1 

2. Add a quick pick list to the Account Manager item with the following labels and values: 

Label Value 

Bates, Elizabeth 172 

Russell, John 145 

Cambrault, Gerald 148 

3. Add a select list item called Country that contains the following query (located in 

/home/oracle/labs/labs/lab_09_02_02.txt). This item should allow nulls. 

select COUNTRY_NAME display_value, COUNTRY_ID return_value 

from OEHR_COUNTRIES 

order by 1 

4. Change the Account Manager of an existing customer record.  

Note: You must navigate to the customer report and edit one of the records. 

5. Create and Modify the Employee Detail form page to take advantage of some of the new 

HTML5 item types and add a LOV using the following query (located in 

/home/oracle/labs/labs/lab_09_02_03.txt).  

select first_name||' '||last_name d, employee_id r 

from oehr_employees 

6. Change the Account Manager of an existing customer record. 
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Catch Up 

If you haven’t completed Practice 2-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_admin user. 

b. Click the arrow next to SQL Workshop and select SQL Scripts. 

c. Click the Upload > button. 

d. Browse and upload the sol_02_01.sql file in the 

/home/oracle/labs/solutions directory. 

e. Run the script by clicking the Run icon. 

f. Click Run Now. 

g. Make sure that the script executed successfully and the apex_dev user is created. 

 

If you haven’t completed Practice 2-3: Installing a Sample Dataset, perform the steps to 

install a sample dataset before you start with Practice 9-2. 

 

If you haven’t completed Practice 9-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_dev user. 

b. Click the arrow next to Application Builder and select Import. 

c. Click the Browse button. 

d. Browse and open the sol_09_01.sql file in the /home/oracle/labs/solutions 

directory and click Next . 

e. Click Next >. 

f. Select Reuse Application ID 111 From Export File for the Install As Application 
option and click Install Application. 

g. Click Replace Application (if prompted). 

h. Wait for the application to successfully install. 
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Solution 9-1: Adding Items and Buttons 

Overview 

In this practice solution, steps are provided for adding items and buttons to the GMT application. 

Steps 

1. Create a blank page called Customer Feedback. Enter the page number as 18. 

a. On the GMT Application Home page, click Create Page. 

 

b. Select Blank Page. 
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c. Enter the Page Attributes: 

 Page Number: Enter 18 

 Name: Enter Customer Feedback

 

d. Click Next >. 

e. Accept the default for Navigation Menu and click Next >.
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f. The Confirm page opens. Click Finish. 

 

g. The Page 18: Customer Feedback page opens in Page Designer.  
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h. To create a region on this page, right-click Regions and select Create Region. 

 

i. In the Property Editor (the right pane), under Identification > Title, enter Customer 

Feedback. 

  

j. Click Save. 
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2. Add the following page items to the Customer Feedback form: 

Items Type 

Customer ID Text Field 

Feedback           Text Area 

Added On Date Picker 

a. To create page items in the Customer Feedback region, right-click Customer 
Feedback and select Create Page Item. 

 

b. Select the Page Item. 

c. In the Property Editor (the right pane): 

 Identification > Name: Enter P18_CUSTOMER_ID 

 Identification > Type: Select Text Field (if not selected by default) 

 Source > Type: Select Database Column 
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 Source > Database Column: Enter CUSTOMER_ID 

 

 

d. Click Save. 
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e. Right-click Customer Feedback and select Create Page Item. 

 

f. In the Property Editor (the right pane): 

 Identification > Name: Enter P18_FEEDBACK 

 Identification > Type: Select  Textarea 

 Source > Type: Select Database Column 

 Source > Database Column: Enter FEEDBACK 
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g. Right-click Customer Feedback and select Create Page Item. 

 

h. In the Property Editor (the right pane): 

 Identification > Name: Enter P18_ADDED_ON 

 Identification > Type: Select  Date Picker 

 Source > Type: Select Database Column 
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 Source > Database Column: Enter ADDED_ON 
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i. You can drag and drop an item to reposition the item in the list. Drag the 

P18_ADDED_ON item to the above P18_FEEDBACK item. 

 

j. Click Save and Run Page. 
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k. On the sign in page, enter your user credentials if prompted. 

 

l. The Customer Feedback page loads with all the fields. Click the Application 111 link 
on the Runtime Developer toolbar. 

 

 

3. Add a button Customer Feedback on the Customers page (page 4) to redirect to the 

Customer Feedback page. 

a. Click Page 4 - Customers page.  

The Customers page opens in Page Designer. 
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b. Click Customers under Content Body. In Property Editor > Identification, enter 

Customer Report in the Title field. 
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c. Now, right-click the Customer Report region and select Create Button. 

 

d. Select Customer Report > Region Buttons > New.  
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e. In the Property Editor (the right pane): 

 Identification > Button Name: Enter CUSTOMER_FEEDBACK. 

 Layout > Button Position: Select Right of Interactive Report Search Bar from 
the drop-down list. 

 Appearance > Template Options > Common > Size: Select Large from the 
drop-down list and click OK. 

 Behavior > Action: Select Redirect to Page in this Application from the drop-
down list. 

 Behavior > Target > Page: Select Customer Feedback (Page 18). 
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f. Click Save and Run Page. 

 

g. Click Customer Feedback. 
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The Customer Feedback page is displayed. Click the Edit Page 18 link on the Runtime 
Developer toolbar. 

 

 

 

4. Add an Apply button on the Customer Feedback page. 
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a. The Page 18: Customer Feedback opens in Page Designer view. You want to create 
an Apply button on this page.  

b. Right-click the Customer Feedback region and select Create Button. 
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c. Select the New button. 

 

d. In the Property Editor (the right pane): 

 Identification > Button Name: Enter APPLY_CHANGES 

 Identification > Label: Enter Apply 

 Appearance > Hot: Click Yes 

 Appearance > Template Options > Default Template Options: In the Template 
Options dialog, under Common > Size, select Large from the drop-down list. 

O
ra

cl
e 

In
te

rn
al

 &
 O

ra
cl

e 
Ac

ad
em

y 
U

se
 O

nl
y



 

Copyright © 2019, Oracle and/or its affiliates. All rights reserved. 

284  Practices for Lesson 9: Adding Items and Buttons 

 Click OK. 

  

 

e. Click Save and then Save and Run Page. 
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f. Notice that the Apply button is created. Click the Edit Page 18 link on the Runtime 
Developer toolbar. 

 

 

5. Add a Cancel button on the Customer Feedback page to redirect to the Customers page. 

a. To redirect to the Customer Feedback page when the Cancel button is clicked, right-
click the Customer Feedback region and select Create Button. 
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b. Select the New button. 

c. In the Property Editor (the right pane): 

 Identification > Button Name: Enter CANCEL. 

 Identification > Label: Enter Cancel (populates by default). 

 Appearance > Template Options > Default Template Options: In the Template 
Options dialog, under Common > Size, select Large from the drop-down list. 

 Click OK. 

 Behavior > Action: Select Redirect to Page in this Application from the drop-
down list. 

 Behavior > Target > Page: Select Page 4 - Customers. 

 Click OK. 
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d. Click Save and then Save and Run Page. 

 

e. The Cancel button is created successfully. Observe that when you click the Cancel 
button, it takes you to the Customers report. Click the Application 111 link on the 
Runtime Developer toolbar. 
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Solution 9-2: Manipulating Items 

Overview 

In this practice solution, steps are provided for modifying the items in the GMT application. 

Steps 

1. Modify the Account Manager item to be a select list with the following query (located in 

/home/oracle/labs/labs/lab_09_02_01.txt): 

select LAST_NAME||', '||FIRST_NAME display_value, EMPLOYEE_ID 

return_value 

from OEHR_EMPLOYEES 

where DEPARTMENT_ID=80 

order by 1 

a. On the GMT Application Home page, click Page 9 - Customer Details. Page 9 – 
Customer Details open in Page Designer view. 

b. Click Save and Run Page. 
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c. You will change the Account Manager Id item to a select list and also add a quick pick 
list. Click the Edit Page 9 link on the Runtime Developer toolbar, 

 

 

d. Page 9: Customer Details opens in Page Designer. Select Regions > Customer 

Details > Items > P9_ACCOUNT_MGR_ID. 
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e. In the Property Editor (the right pane): 

 Identification > Type: Select  Select List 

 Label > Label: Account Manager 

 List of Values > Type: Select SQL Query from the drop-down list. 

 List Of Values > SQL Query: Enter the following query (located in 

/home/oracle/labs/labs/lab_09_02_01.txt) to display the last name 

and first name and return EMPLOYEE_ID.  

select LAST_NAME||', '||FIRST_NAME display_value, 

EMPLOYEE_ID 

return_value 

from OEHR_EMPLOYEES 

where DEPARTMENT_ID=80 

order by 1 

 List of Values > Display Null Value: Click Yes (if not selected by default) 

 List of Values > Null Display Value: Enter -Select Manager- 
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f. Click Save. 

 

2. Add a quick pick list to the Account Manager item with the following labels and values: 

Label Value 

Bates, Elizabeth 172 

Russell, John 145 

Cambrault, Gerald 148 

a. In the Property Editor (the right pane), select P9_ACCOUNT_MGR_ID > Quick Picks > 

Show Quick Picks: Select Yes. 
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b. Enter the following labels and values. 

Label Value 

Bates, Elizabeth 172 

Russell, John 145 

Cambrault, Gerald 148 

 

c. Click Save and then Save and Run Page. 

 

d. Click the Account Manager drop-down list to see the list of Account Managers. 

e. Click anywhere on the page and then click the Russell, John quick pick. 
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f. Notice how the name is selected for the Account Manager drop-down list. Click the 
Edit Page 9 link on the Runtime Developer toolbar. 

 

 

Customer Details page opens in Page Designer. 

 

3. Add a select list item called Country that contains the following query (located in 

/home/oracle/labs/labs/lab_09_02_02.txt). This item should allow nulls. 

select COUNTRY_NAME display_value, COUNTRY_ID return_value 

from OEHR_COUNTRIES 

order by 1 

a. Open Page 9 in Page Designer and go to Regions > Customer Details. Right-click 
Customer Details region and select Create Page Item. 
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b. Click the new Page Item P9_NEW. 

c. In the Property Editor (the right pane): 

 Identification > Name: Enter P9_COUNTRY_ID 

 Identification > Type: Select Select List from the drop-down list 

 Label > Label: Enter Country 

 List of Values > Type: Select SQL Query from the drop-down list 

 List of Values > SQL Query: Enter the following query < located in 

/home/oracle/labs/labs/lab_09_02_02.txt in this field> 

select COUNTRY_NAME display_value, COUNTRY_ID return_value 

from OEHR_COUNTRIES 

order by 1 

 List of Values > Null Display Value: Enter -Select Country- 

 Source > Type: Select Database Column from the drop-down list 
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 Source > Type > Database Column: Enter COUNTRY_ID 
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d. Select Region Buttons > Cancel on the Rendering tab. 

 

e. In the Property Editor (the right pane): 

 Appearance > Template Options: Click Use Template Default. 

O
ra

cl
e 

In
te

rn
al

 &
 O

ra
cl

e 
Ac

ad
em

y 
U

se
 O

nl
y



 

Copyright © 2019, Oracle and/or its affiliates. All rights reserved. 

Practices for Lesson 9: Adding Items and Buttons  299 

 Column: Common > Size: Select Large from the drop-down list. 

 Click OK. 

 

f. Click Save and then Save and Run Page. 

 

g. Notice that the Country item shows a select list of country names. Notice also the 
large size of the Cancel button. Click the Application 111 link on the Runtime 
Developer toolbar. 
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4. Change the Account Manager of an existing customer record.  

Note: You must navigate to the customer report (page 4) and edit one of the records. 

a. Open Page 4:  Customers in Page Designer view. 

b. Click Save and Run Page 

.  

c. To modify an existing record, click the Customers tab on the left pane.  
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d. Click the Edit icon for one of the rows. The Customer Details page opens.  

 

e. You want to make one more change on the Customer Details page so that the Apply 
Changes button appears larger. Click Quick Edit on the Runtime Developer toolbar 

and select the  icon next to Apply Changes button. 
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f. The Live Template Options page is displayed.  

In Live Template Options, for Common > Size, select Large from the drop-down list. 

 

g. Click Save. 
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h. Notice the change in Apply Changes button size. 

 

i. Click the Application 111 link on the Runtime Developer toolbar. 

 

 

5. Create and modify the Employee Detail (19 – Employee Detail) page to take advantage of 

some of the new HTML5 item types. Note: This is mainly for enhancing the user interface. 

The user creates a subtype for Email, Phone Number, and Manager ID in a select list on a 

Form page. This ensures that the page uses the appropriate keyboard for email and phone 

numbers while entering the relevant values in the form. 

a. You will first create a Form Page.  

i. Go to your Application 111 and click Create Page.  
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ii. Create Form. 

 

iii. Click Next.  

iv. Select Form. 

 

v. Enter the following details and click Next >.  

 Page Number: Enter 19 

 Page Name: Enter Employee Details 

 Branch Here on Submit: Select 1 

 Cancel and Go To Page: Select 1 
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vi. Select default Navigation Preference and click Next >. 
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vii. For Table/View Owner, select OEHR (if not selected by default). For Table/View 

Name, select OEHR_EMPLOYEES (table). Click Next.  

 

viii. Select Select Primary Key Column(s) for Primary Key Type. For Primary Key 
Column, select EMPLOYEE_ID (Number). Cick Create.  

 

ix. The form page is created and opens in Page Designer view.  

b. You want to add a new column to the OEHR_EMPLOYEES table to store whether an 

employee is active or not. Select SQL Workshop > Object Browser. 
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c. Select the appropriate schema. Here you select OEHR.  
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d. Select OEHR_EMPLOYEES from the Tables list. 

  

e. Click Add Column. 

 

f. Enter the following: 
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 Add Column: Enter ACTIVE_YN 

 Type: Select VARCHAR2 

 Length: Enter 1 

 

 Click Next. 

g. Click Finish. 

 

 

6. Now you can modify the Employee Detail form page.  

a. Click the Application Builder pull-down menu and select Database Applications. 
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b. Navigate to the GMT application page. Click the GlobalMart Management Tool icon. 

 

c. Click the View Report icon. 

 

d. Select Page 19 - Employee Details. 
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e. Change the setting for email. In the Rendering tab, select P19_EMAIL. 

 

f. In the Property Editor (the right pane): 

 Settings > Subtype: Select E-Mail 

 

g. Change the subtype for Phone Number. In the Rendering tab, select 

P19_PHONE_NUMBER. 
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h. In the Property Editor (the right pane): 

 Settings > Subtype: Select Phone Number 
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i. Change Manager to show a select list. In the Rendering tab, select 

P19_MANAGER_ID. 

 

j. In the Property Editor (the right pane): 

 Identification > Type: Select Select List from the drop-down list 

 List of Values > Type: Select SQL Query from the drop-down list 

 List of Values > SQL Query: Enter the SQL Query <located in 

/home/oracle/labs/labs/lab_09_02_03.txt in this field> 

select first_name||' '||last_name d, employee_id r 

from oehr_employees 
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k. Create a new page item for the ACTIVE_YN column you added to the EMPLOYEES 

table previously.  

i. Select Create Form under Regions > Content Body, and in the Property Editor 

Identification > Title, enter Employee Details. 
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ii. Right-click Employee Details and select Create Page Item. 
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l. In the Property Editor (the right pane): 

 Identification > Name: Enter  P19_ACTIVE 

 Identification > Type: Select Switch from the drop-down list 

 Source > Type: Select Database Column from the drop-down list 

 Source > Database Column: Enter P19_ACTIVE 

 

 

m. Click Save and then Save and Run Page. 
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n. The Employee Details form displays the Manager Id drop-down list and the Active 

toggle bar. Click the Application 111 link on the Runtime Developer toolbar. 
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Practices for Lesson 10: Overview 

Overview 

There is one practice for this lesson. In this practice, you examine how session state works in 

an Application Express application. 
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Practice 10-1: Understanding Session State 

Overview 

In this practice, you: 

 Modify the Create button on the Customers page of the GlobalMart Management Tool 
(GMT) application. 

 You clear the cache so that when the button is clicked, the Customer Details form is 
empty.  

 You review what is in session URL and then review the change in URL on the Customer 
Details page, after including a new value. 

 Update the title on the Customer Details page to include the customer first name and 
last name. 

Assumptions 

You have completed the previous practices.  

Note: If you have not completed the previous practices, execute the steps mentioned in the 

Catch Up section of this practice. 

Tasks 

1. On the Customers page in the GlobalMart Management Tool (GMT) application, update the 

Create button to make it larger by editing Template Options. 

2. Save and then run the page and to view the changes. 

3. Move your cursor on the Edit option of an existing record and view session URL.  

4. Change the Link Column on the Customers report to include the value for the 

P9_CUST_FIRST_NAME item. 

5. On the Customer Details page, change the title of the Customer Details region to use the 

following (located in /home/oracle/labs/labs/lab_10_01.txt).  

&P9_CUST_FIRST_NAME. &P9_CUST_LAST_NAME. Customer Details 

6. Run the page. What do you observe? 

Catch Up 

If you haven’t completed Practice 2-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_admin user. 

b. Click the arrow next to SQL Workshop and select SQL Scripts. 

c. Click the Upload > button. 

d. Browse and upload the sol_02_01.sql file in the 

/home/oracle/labs/solutions directory. 

e. Run the script by clicking the Run icon. 

f. Click Run Now. 

g. Make sure that the script executed successfully and the apex_dev user is created. 

 

O
ra

cl
e 

In
te

rn
al

 &
 O

ra
cl

e 
Ac

ad
em

y 
U

se
 O

nl
y



 

Copyright © 2019, Oracle and/or its affiliates. All rights reserved. 

322  Practices for Lesson 10: Understanding Session State 

If you haven’t completed Practice 2-3: Installing a Sample Dataset, perform the steps to 

install a sample dataset before you start with Practice 10-1. 

 

If you haven’t completed Practice 9-2, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_dev user. 

b. Click the arrow next to Application Builder and select Import. 

c. Click the Browse button. 

d. Browse and open the sol_09_02.sql file in the /home/oracle/labs/solutions 

directory and click Next. 

e. Click Next. 

f. Select Reuse Application ID 111 From Export File for the Install As Application 

option and click Install Application. 

g. Click Replace Application (if prompted). 

h. Wait for the application to successfully install. 
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Solution 10-1: Understanding Session State 

Overview 

In this practice solution, steps are provided for: 

 Creating and modifying a Create button on the Customers page in the GlobalMart 
Management Tool (GMT) application 

 Reviewing change in session URL on the Customer Details page 

 Changing Link Column on the Customers report to include a new value 

 Updating the title on the Customer Details page to include the customer first name and last 
name 

Steps 

1. On the Customers page in the GMT application, create and edit the CREATE button to 

make it larger. 

a. On the GMT application homepage, click the 4 - Customers page. Page 4 – 
Customers opens in Page Designer. 

b. Right-click Region Buttons and click Create Button. 
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c. In Property Editor, define the button as follows: 

 Button Name: Enter CREATE  

 Label: Create (populated by default) 

 Layout > Region: Select Customer Report (populated by default) 

 Layout > Button Position: Select Right of Interactive Report Search Bar 

 

d. Change the size of the Create button by editing Template Options. In the Property 
Editor under Appearance > Template Options, click the Use Template Defaults 
button. 
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e. In the Template Options dialog, for Common > Size, select Large and click OK. 

 

 

2. Link the button to Page 9 – Customer Details and also clear the cache. To do so, select 

the Create button on the Rendering tab and in Property Editor and define the behavior. 

a. In Property Editor, go to Behavior > Action and select Redirect to Page in this 

Application. 
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b. Under Behavior > Target, click Link to Custom Target. In the Link Builder - Target 

window, for Page select 9. In the Clear Cache field, select page 9. 

  

 

 

3. Save and then run the page to view the changes. 

a. Click Save and Run Page. 
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b. If prompted, enter your workspace credentials and click Sign In. 

 

c. The report is displayed. Notice that the Create button is now displayed next to the 

Customer Feedback button. Also, when you click any existing entry, it re-directs you 

to the Customer Details form. 
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d. Click Cancel and go back to the Customer report. Note that, if you click the Create 

button, it is empty. You do not get any data from the cache. You can create your new 

records here if you want to. 
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Click the Application 111 link on the Runtime Developer toolbar. 

 

 

4. Move your cursor over the Edit icon of an existing record and view session URL.   

a. Click Page 4: Customers.  
b. Page 4: Customers open in Page Designer view. Click Save and Run Page. 
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c. Move your cursor over the Edit icon for any row in the report. Notice on the 
browser’s status bar below that CUSTOMER_ID are being passed in the session 
URL. 

 

The values on the Customer Details page are based on the value stored in 

P9_CUSTOMER_ID. The reason the other values are not displayed in the URL is 

because they have not been submitted to the page.  

d. Click Edit Page 4 on the Runtime Developer toolbar. 
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5. Change the Link Column on the Customers Report to include the value for the 

P9_CUST_FIRST_NAME item. 

a. In the Rendering tab, expand Regions > Content Body > Customer Report and 
then select the Attributes node. 

 

b. In the Property Editor, under Link > Target, click Page 9. 
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c. The Link Builder – Target dialog appears. Under Set Items, note that the name for 

the first item is P9_CUSTOMER_ID and the value is #CUSTOMER_ID#. 

 

d. Add another item name/value.   Under Value, click the  icon and select the 
following for Pick Set Items.  

 Name: Select P9_CUST_FIRST_NAME 
 Value: Select  #CUST_FIRST_NAME#  

e. Click OK. 
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f. Click Save and Run Page. 
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g. Now again move your cursor over the Edit icon for any row in the report. Notice on 

the browser’s status bar that CUSTOMER_ID and CUST_FIRST_NAME are both being 

passed in the URL.  

 

Click Application 111 on the Runtime Developer toolbar. 

 
 
 

6. On Page 9: Customer Details, change the title of the Customer Details region to 

use the following (located in /home/oracle/labs/labs/lab_10_01.txt).  

&P9_CUST_FIRST_NAME. &P9_CUST_LAST_NAME. Customer Details 

a. Open Page 9: Customer Details in Page Designer view. 

b. In the Rendering tab, under Regions > Content Body select the Customer 
Details region. 

  

c. In the Property Editor, change Identification > Title from Customer Details to 

the following (located in /home/oracle/labs/labs/lab_10_01.txt).  

&P9_CUST_FIRST_NAME. &P9_CUST_LAST_NAME. Customer Details 

Note: In the preceding text, the period (.) at the end of the item name is required. 
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i. Click Save and Run Page. 

  

ii. The Customer Details form opens. Click Cancel to go to the Customers 
report page. 
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iii. Click the Edit option to open any existing record. What do you observe? 
Notice that the Customer Name is included in the title for the displayed 
record. 
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d. Return to the App Builder home page. Click Home on the Runtime Developer 
toolbar. 
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Practices for Lesson 11: Overview 

Overview 

In this practice, you examine how computations, processes, and validations work. 
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Practice 11-1: Creating and Manipulating Computations, Processes, 

and Validations 

Overview 

In this practice, you create the following computations, processes, and validations on multiple 

pages in the GlobalMart Management Tool application:  

 Create a Page Processing computation that changes an email address to uppercase.  

 Create a Page Rendering computation to populate a new item on a page. 

 Create an On Submit process to populate an Audit table to track changes to order 

items.  

 Examine the built-in Value Required validation for page items.  

 Create a validation to verify that a value is greater than zero.  

 Create an item string comparison validation to ensure that there are no spaces in a 

Cust Email field. 

Note: If you do not intend to create the table OEHR_ORDER_ITEMS_AUDIT that is part of this 

practice, then you must run the script create_table_oehr_order_items_audit.txt 

located in /home/oracle/labs/labs/ create_table_oehr_order_items_audit.txt 

Assumptions 

You have completed the previous practices.  

Note: If you haven’t completed the previous practices, execute the steps mentioned in the 

Catch Up section of this practice. 

Tasks 

1. Page processing computation. Create a page processing computation that changes the 

email address on the Customer Details page to uppercase after the page is submitted. 

2. Page Rendering computation. Create a Page Rendering computation that populates a new 

item on the Order Details page with the List Price from the OEHR_PRODUCT_INFORMATION 

table. 

3. On Submit process. Create an audit table, which tracks changes to order items. To 

accomplish this, you create a new table by copying the OEHR_ORDERS_ITEMS table and 

adding two new columns, Updated and Updated By. You populate the new Audit table by 

creating an On Submit process. 

4. Examine the Value Required validation that exists on some items. Certain items on the 

Customer Details page are marked as required. This behavior is controlled by the Page 

Item validation, Value Required.  Examine the Value Required validation that exists on 

some items on the Customer Details page.  

5. Create a validation to verify that a value is greater than zero. On the Order Items page, 

create a validation on the Quantity field to ensure that it has a value that is greater than 

zero. 

O
ra

cl
e 

In
te

rn
al

 &
 O

ra
cl

e 
Ac

ad
em

y 
U

se
 O

nl
y



 

Copyright © 2019, Oracle and/or its affiliates. All rights reserved. 

342  Practices for Lesson 11: Including Page Processing 

6. Create an item string comparison validation to ensure that there are no spaces in the Cust 

Email field. Create an item string comparison validation to ensure that there are no spaces 

in the Cust Email field on the Customer Details page. 

Catch Up 

If you haven’t completed Practice 2-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_admin user. 

b. Click the arrow next to SQL Workshop and select SQL Scripts. 

c. Click the Upload > button. 

d. Browse and upload the sol_02_01.sql file in the 

/home/oracle/labs/solutions directory. 

e. Run the script by clicking the Run icon. 

f. Click Run Now.  

g. Make sure that the script executed successfully and the apex_dev user is created. 

 

If you haven’t completed Practice 2-3: Installing a Sample Dataset, perform the steps to 

install a sample dataset before you start with Practice 11-1. 

 

If you haven’t completed Practice 10-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_dev user. 

b. Click the arrow next to Application Builder and select Import. 

c. Click the Browse button. 

d. Browse and open the sol_10_01.sql file in the /home/oracle/labs/solutions 

directory and click Next >. 

e. Click Next >. 

f. Select Reuse Application ID 111 From Export File for the Install As Application 
option and click Install Application. 

g. Click Replace Application (if prompted). 

h. Wait for the application to successfully install. 
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Solution 11-1: Creating and Manipulating Computations, Processes, 

and Validations 

Overview 

In this practice solution, steps are provided for creating and manipulating computations, 

processes, and validations. 

Note: If you do not intend to create the table OEHR_ORDER_ITEMS_AUDIT that is part of this 

practice, then you must run the script create_table_oehr_order_items_audit.txt 

located in /home/oracle/labs/labs/ create_table_oehr_order_items_audit.txt 

Steps 

1. Create a page processing computation that changes the email address on the Customer 

Details page to uppercase after the page is submitted. 

a. On the GMT Application home page, select page 9 - Customer Details page. 

 

b. Page 9 – Customer Details opens in Page Designer view. In the left pane of Page 

Designer, click the Rendering tab. 
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c. On the Page Rending tab, scroll down and expand Post Rendering. Right-click After 

Regions and select Create Computation. 

 

d. Ensure that the new computation is selected. In the Property Editor, edit the following: 

 Identification > Item Name: Enter P9_CUST_EMAIL. 

 Execution Options > Point: Select After Submit. 

 Computation > Type: Select PL/SQL Expression. 

 Computation > PL/SQL Expression: Enter upper(:P9_CUST_EMAIL). 
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e. Click Save and then Save and Run Page. 
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f. If prompted, enter your workspace user credentials and click Sign In. 
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g. Click Cancel to return to the Customers report.  
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h. On the Customers page, click the Edit icon in a row. 

 

i. Notice that the email is currently in mixed case format. Click Apply Changes to invoke 
the computation. 
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j. On the Customer Report, scroll to the right and look at the Cust Email column. Notice 
that the email for the edited record (highlighted in red) now appears in uppercase.  

 

k. Click Application 111 on the Runtime Developer toolbar at the bottom of the window. 

 

2. Create a Page Rendering computation that populates a new item on the Order Details page 

with the List Price from the OEHR_PRODUCT_INFORMATION table.  

a. On the GMT Application home page, select page 14 – Oehr Order Items. 

 

b. Create a Display Only item: 

i. On the Layout tab, find the Oehr Order Items region. 
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ii. From the Gallery at the bottom of the central pane, select the Items tab.  
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iii. Select Display Only and drag it after the P14_UNIT_PRICE. 

 

iv. Select P14_NEW and enter the following values: 

 Identification > Title: Enter P14_LIST_PRICE and press Enter. 

 Source > Type: Select Null (if not selected by default). 
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c. Create a Pre-Rendering Computation: 

i. On the Rendering tab, expand Pre-Rendering. 

ii. Right-click Before Regions and select Create Computation. 

 

d. In the Property Editor, edit the following: 

i. Identification > Item Name: Select P14_LIST_PRICE. 

ii. Computation > Type: Select SQL Query (return single value), if not selected 

by default. 

iii. Source > SQL Query: Copy and paste the following code located in 

/home/oracle/labs/labs/lab_11_01_01.txt). 

select list_price 

from oehr_product_information 

where product_id = :P14_PRODUCT_ID O
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e. Click Save. 

f. Review your changes. Because page 14 – Order Items is a modal dialog, you cannot 

run it directly from Page Designer. 

i. In the Page Selector, in the Page Designer toolbar, enter 12 and click Go. 

 

ii. When page 12: List of Order appears, click Save and Run Page. 
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iii. If prompted, enter your workspace user credentials and click Sign In. 

 

iv. On the page 12 - List of Orders, select an order in the left, Master Record 

region. 

v. Scroll down in the right pane. Under Order Details, select Line Item by 

clicking the Edit icon. 

 

The Order Items dialog box appears. Notice that List Price now appears after the 

Unit Price. 
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vi. Click Cancel to exit the Order items dialog box. 

g. Click Application 111 on the Runtime Developer toolbar to return to the Application 

home page.  

 

3. Create an audit table, which tracks changes to order items. To accomplish this, you create 

a new table by copying the OEHR_ORDERS_ITEMS table and adding two new columns, 

UPDATED and UPDATED BY. You populate the new Audit table by creating an On Submit 

process. 

a. Open Object Browser on a new browser tab. 

i. On the Application home page, find the SQL Workshop menu at the top of 

the page.  

ii. Click the down arrow next to SQL Workshop.  

iii. Right-click Object Browser and select Open Link in New Tab.  
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iv. Click the new browser tab, named Object Browser. 

b. Create a copy of the OEHR_ORDER_ITEMS table. In the Object Selection pane, select 

the OEHR_ORDER_ITEMS table and then click the Copy tab in the Details pane. 

 

c. In the Copy Table Wizard: 

i. New Table: Enter OEHR_ORDER_ITEMS_AUDIT. 

ii. Display: Select No Rows. 

This option ensures that the wizard only creates the structure but does not 

copy any columns. 

 

iii. Click Next. 
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iv. Click Finish.  

 

d. Add a column named updated. In the Object Selection pane, select the 

OEHR_ORDERS_ITEMS_AUDIT table and click the Add Column tab in the Details pane. 

 

e. In the Add Column Wizard: 

i. Add Column: Enter UPDATED. 
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ii. Type: Select TIMESTAMP WITH LOCAL TIMEZONE. 

 

iii. Click Next. 

iv. Click Finish. 
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f. Add a column named UPDATED_BY. In the Object Selection pane, ensure 

OEHR_ORDERS_ITEMS_AUDIT is still selected and click the Add Column tab in the 

Details pane. 

 

g. In the Add Column Wizard: 

 Add Column: Enter UPDATED_BY. 

 Type: Select VARCHAR2. 

 Length: Enter 255. 

 

 Click Next. 

 Click Finish.  
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OEHR_ORDERS_ITEMS_AUDIT now contains two new columns: UPDATED and 

UPDATED_BY. 
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h. Select Database Application; click the GMT application to return to your application. 

 

i. Click page 14 – Oehr Order Items to open it in Page Designer.  

j. Create a new process to insert columns into the OEHR_ORDERS_ITEMS_AUDIT table: 

i. In the left pane, click the Processing tab .  

ii. Expand Processing, right-click Processes, and select Create Process.  
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iii. Select the New process and drag it after Process form OEHR ORDER 

ITEMS.  

 

k. On the Rendering tab, ensure that the New process is selected. In the Property Editor, 

edit the following: 

i. Identification > Name: Enter Save Audit and press Enter. 

ii. Source > PL/SQL Code: Click the Code Editor: PL/SQL Code icon. 
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iii. In the Code Editor, copy and paste the following Pl/SQL code (located in 

/home/oracle/labs/labs/lab_11_01_02.txt) and click OK: 

insert into OEHR_ORDER_ITEMS_AUDIT 

 (  order_id 

  , order_item_id 

  , line_item_id 

  , product_id 

  , unit_price 

  , quantity 

  , updated 

  , updated_by 

 ) 

 values 

 (  :P14_ORDER_ID 

  , :P14_ORDER_ITEM_ID 

  , :P14_LINE_ITEM_ID 

  , :P14_PRODUCT_ID 

  , :P14_UNIT_PRICE 

  , :P14_QUANTITY 

  , SYSDATE 

  , :APP_USER 

 ); 
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l. Click Save. 

 

 

3. Test your changes. Because Page 15 – Oehr Order Items is a modal dialog, you cannot 

run it directly from Page Designer. Navigate to and then run page 12. 

a. In the Page Selector, in the Page Designer toolbar, enter 12 and click Go. 

 

b. When Page 12: List of Order appears, click Save and Run Page. 

 

c. If prompted, enter your workspace user credentials and click Sign In. 

On the List of Orders page, select an order in the left, Master Record region. 

d. Scroll down in the right pane. Under Order Details, select Line Item by clicking the Edit 

icon. 

 

  

O
ra

cl
e 

In
te

rn
al

 &
 O

ra
cl

e 
Ac

ad
em

y 
U

se
 O

nl
y



 

Copyright © 2019, Oracle and/or its affiliates. All rights reserved. 

Practices for Lesson 11: Including Page Processing  365 

e. Edit the price and quantity for an order in the Order Items dialog box (for Product ID 

2402): 

 Unit Price: Change to 300. 

 Quantity: Change to 50. 

 Click Apply Changes. 

 

The message “Oehr Order items updated” appears. 
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f. View the OEHR_ORDERS_ITEMS_AUDIT table in Object Browser and see if the 

new table records the change. 

i. Navigate to Object Browser. 

ii. In the Object Selection pane, select the OEHR_ORDERS_ITEMS_AUDIT 

table. 

 

iii. In the Details pane, click the Data tab.  

 

Notice that the changes you just made in the Order Details dialog box appear. 

Also, notice the Updated and Updated By columns are populated. 
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g. Exit Object Browser and return to your running application. 

h. Click Application 111 on the Runtime Developer toolbar to return to the Application home 

page.  

 

 

4. Certain items on the Customer Details page are marked as required. You can enable or 

disable this behavior by configuring the Page Item validation, Value Required. Examine the 

Value Required validation that exists on some items on the 9 - Customer Details page.  

a. Open page 4 - Customers in Page Designer view.  

b. Click Save and Run Page. 

c. On the Customers interactive report, click the Edit icon to view the Customer Details 
page. 
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d. Notice that Cust First Name and Cust Last Name fields are marked with a red 
triangle in the upper-left corner. This red triangle means that the items must have a 
value.  

 

e. Delete the value in the Cust First Name field and click Apply Changes. 

f. An error message appears stating that you must fill out the field. You can enable or 
disable this validation by editing the attributes for the item.  

 

g. Click OK to exit the error message. 

h. Review the attributes that define the Cust Last Name and control this validation. 
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i. Click the Quick Edit link on the Runtime Developer toolbar. 

 

ii. Select the Cust First Name field. 

 

i. Page Designer opens with the item P9_CUST_FIRST_NAME selected. 
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j. In the Property Editor, find the attribute Validation > Value Required. 

 

Note that Value Required is set to Yes.  

Note: As an alternative, you could set Value Required to No and manually create a 

Not Null validation on this item. The advantage of this approach is that you can then 

create and custom the error message. 

k. Click the Application 111 breadcrumb to return to the Application home page.  

 

 

5. On the Order Items page, create a validation on the Quantity field to ensure that it has a 

value that is greater than zero. 

a. On the Application home page, select page 14 – Oehr Order Items. 

b. In the left pane of Page Designer, click the Processing tab . 

c. Right-click Validating and select Create Validation. 
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d. On the Processing tab, ensure that the newly created validation is selected. 

 

e. In the Property Editor, edit the following: 

 Identification > Name: Enter Quantity Validation. 

 Validation > Type: Select Item is NOT NULL or zero. 

 Validation > Item: Select P14_QUANTITY. 

 Error > Error Message: Enter Quantity must be greater than 0. 
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 Click Save. 

f. See how the validation works by running the page.  

i. In Page Selector, in the Page Designer toolbar, enter 12 and click Go. 

 

ii. When page 12: List of Order appears, click Save and Run Page. 

 

iii. If prompted, enter your workspace user credentials and click Sign In. 
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iv. On the List of Orders page, select an order in the left, Master Record region. 

v. Scroll down in the right pane. Under Order Details, select a Line Item by clicking the 

Edit icon. 

 

vi. In the Quantity field in the Order Items dialog box, enter 0 and click Apply Changes. 

An error message appears that reads Quantity must be greater than 0. 

 

vii. Click Cancel to exit the Order Items dialog box. 

viii. Click Application 111 on the Runtime Developer toolbar to return to the Application 

home page.  

O
ra

cl
e 

In
te

rn
al

 &
 O

ra
cl

e 
Ac

ad
em

y 
U

se
 O

nl
y



 

Copyright © 2019, Oracle and/or its affiliates. All rights reserved. 

374  Practices for Lesson 11: Including Page Processing 

 

 

6. Create an item string comparison validation to ensure that there are no spaces in the Cust 

Email field on the Customer Details page. 

a. On the Application home page, select the page, 9 - Customer Details. 

b. In the left pane of Page Designer, click the Processing tab . 

Note: The Processing tab should already be selected. 

c. Right-click Validating and select Create Validation. 

 

d. On the Processing tab , ensure that the newly created validation is selected. 

 

e. In the Property Editor, edit the following: 

 Identification > Name: Enter Email Validation. 

 Validation > Type: Select Item contains no spaces. 

 Validation > Item: Select P9_CUST_EMAIL. 
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 Error > Error Message: Enter Email must not contain spaces. 

 Error > Display Location: Selected by default: Inline with Field and in 
Notification 

 

 

 Server Side Condition > Type: Select Item is NOT NULL. 

Note: You want this validation to fire only when the item is not null. O
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 Server-side Condition > Item: Select P9_CUST_EMAIL. 

 

f. See how the validation works. Click Save and Run Page. 

 

l. Click Cancel to go to the 4 - Customers page.  

m. Click the Edit button next to any record. 

n. Edit the Cust Email field by adding a space to the email address and click Apply 
Changes. 

 

An error message is displayed inline and also at the top of the page. 
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o. Remove the space you added in the Cust Email field and click Apply Changes again. 

The Customers interactive report displays again without the error messages.  

Note that if you have added Email as Subtype for the Email item, then it also runs this 

validation check in case you enter an invalid character (for example “space”) while 

entering the customer email address in the Customer Details form. 

p. Click Cancel to exit the Customer Details page. 

q. Click Application 111 on the Runtime Developer toolbar. 
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Practices for Lesson 12: Overview 

Practices Overview 

In these practices, you examine how dynamic actions and plug-ins work. 
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Practice 12-1: Using Dynamic Actions on Your Page 

Overview 

In this practice, you create dynamic actions in the GlobalMart Management Tool application. 

Assumptions 

You have completed the previous practices. 

Note: If you haven’t completed the previous practices, execute the steps mentioned in the Catch Up 
section of this practice. 

Tasks 

1. Show Item when another item is Not Null: On the Customer Details page, show 

P9_CUST_EMAIL only if the P9_CUST_FIRST_NAME is not null. 

2. Refresh report data using custom filters:  On the Customers page, create a Quick Filter 

region with two select list items P4_CUSTOMER_ID and P4_CITY_ID. Create a dynamic action 

on the select lists to refresh the report when the values of the select list change. 

Catch Up 

If you haven’t completed Practice 2-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_admin user. 

b. Click the arrow next to SQL Workshop and select SQL Scripts. 

c. Click the Upload > button. 

d. Browse and upload the sol_02_01.sql file in the /home/oracle/labs/solutions 

directory. 

e. Run the script by clicking the Run icon. 

f. Click Run Now. 

g. Make sure that the script executed successfully and the apex_dev user is created. 

 

If you haven’t completed Practice 2-3: Installing a Sample Dataset, perform the steps to install a 

sample dataset before you start with Practice 12-1. 

 

If you haven’t completed Practice 11-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_dev user. 

b. Click the arrow next to Application Builder and select Import. 

c. Click the Browse button. 

d. Browse and open the sol_11_01.sql file in the /home/oracle/labs/solutions 

directory and click Next >. 

e. Click Next >. 

f. Select Reuse Application ID 111 From Export File for the Install As Application option 
and click Install Application. 

g. Click Replace Application (if prompted). 
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h. Wait for the application to successfully install. 
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Practice 12-2: Importing and Using Plug-Ins on Your Page 

Overview 

In this practice, you import and use an item type plug-in and a dynamic action plug-in. 

Note: The solution script generated at the end of this practice does not contain the Rating column. 

Assumptions 

You have completed the previous practices. 

Note: If you haven’t completed the previous practices, execute the steps mentioned in the Catch Up 
section of this practice. 

Tasks 

1. Add a rating column to the CUSTOMERS table. 

2. Import the Modern Star Rating Item plug-in. 

3. Add the Modern Star Rating plug-in to your Customer Details page. 

Catch Up 

If you haven’t completed Practice 2-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_admin user. 

b. Click the arrow next to SQL Workshop and select SQL Scripts. 

c. Click the Upload > button. 

d. Browse and upload the sol_02_01.sql file in the /home/oracle/labs/solutions 

directory. 

e. Run the script by clicking the Run icon. 

f. Click Run Now. 

g. Make sure that the script executed successfully and the apex_dev user is created. 

 

If you haven’t completed Practice 2-3: Installing a Sample Dataset, perform the steps to install a 

sample dataset before you start with Practice 12-2. 

 

If you haven’t completed Practice 12-1, perform the following steps: 

a. Sign in to the Application Express workspace as the apex_dev user. 

b. Click the arrow next to Application Builder and select Import. 

c. Click the Browse button. 

d. Browse and open the sol_12_01.sql file in the /home/oracle/labs/solutions 

directory and click Next >. 

e. Click Next >. 

f. Select Reuse Application ID 111 From Export File for the Install As Application option 
and click Install Application. 

g. Click Replace Application (if prompted). 

h. Wait for the application to successfully install. 
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Solution 12-1: Using Dynamic Actions on Your Page 

Overview 

In this practice, you create various dynamic actions on the Customer Details page. 

Steps 

1. Show Item when another item is Not Null: On the Customer Details page, show 

P9_CUST_EMAIL only if the P9_CUST_FIRST_NAME is not null. 

a. On the Application home page, select 9 - Customer Details page. 

   

b. Page Designer appears, displaying Page 9: Customer Details. Click Save and Run 

Page.  
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c. If you are prompted to sign in, enter your workspace credentials and click Sign In. 

 

d. The Customer Details page appears. Add a dynamic action that shows the Cust Email 

field only if the user enters a value in Cust First Name. 

 

e. Click the Edit Page 9 icon on the Runtime Developer toolbar. 
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f. On the Rendering tab, right-click P9_CUST_FIRST_NAME and select Create Dynamic 

Action.  

 

A new dynamic action appears on the Rendering tab under P9_CUST_FIRST_NAME. 
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g. Select the New dynamic action. In the Property Editor (right pane), enter the following: 

 Identification > Name: Enter Show Email. 

 Client Side Condition > Type: Select Item is not null. 

  

  

O
ra

cl
e 

In
te

rn
al

 &
 O

ra
cl

e 
Ac

ad
em

y 
U

se
 O

nl
y



 

Copyright © 2019, Oracle and/or its affiliates. All rights reserved. 

Practices for Lesson 12: Using Dynamic Actions and Plug-Ins  389 

h. On the Rendering tab (left pane), select Show Email > True > Show.  
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i. In the Property Editor (right pane), enter the following: 

 Identification > Action: Select Show (selected by default).  

 Affected Elements > Selection Type: Select Item(s). (selected by default) 

 Affected Elements > Item(s): Select P9_CUST_EMAIL. 
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j. On the Rendering tab, right-click Show Email > False and select Create FALSE Action.  
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k. Ensure that Show Email > False > Show is selected on the Rendering tab. 

 

l. In the Property Editor, enter the following: 

 Identification > Action: Select Hide.  

 Affected Elements > Selection Type: Select Item(s) (selected by default). 

 Affected Elements > Item(s): Select P9_CUST_EMAIL. 
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m. Click Save and then the Save and Run Page. 
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Notice that when you first run the page, and there is no value in the Cust First Name field, 

the Cust Email field is no longer displayed. This is because of the dynamic action you just 

created. 

 

n. Enter Test in the Cust First Name field and then click outside the field. Notice that the 

Cust Email field reappears.  

 
Delete your entry in the Cust First Name field and click outside the field. Notice that the 

Cust Email field disappears.  
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o. Click the Application 111 link on the Runtime Developer toolbar. 

 

 

2. Refresh report data using custom filters:  On the Customers page, create a Quick Filter 

region with two select list items P4_CUSTOMER_ID and P4_CITY_ID. Create a dynamic action 

on the select lists to refresh the report when the values of the select list change. 

a. On the Application home page, select the Customers page. 

 

b. Click the Save and Run Page.  

 

c. On the Customers report, change the columns that display in the report.  

i. Click the Actions menu and select Columns.  
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ii. In the Select Columns dialog box, select Customer Id, click Remove (<), and 

then click Apply. 
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d. Save a new Primary, Default Report.  

i. Click the Actions menu and then select Report and Save Report. 

 

ii. The Save Report dialog box appears. From Save, select As Default Report 

Settings. 

 

iii. The Save Default Report dialog box appears. Select Primary and click Apply. 
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e. The report settings are saved. Click the Edit Page 4 link on the Run Developer toolbar. 

 

f. On Page 4: Customers, create the region to contain the filtered item.  

i. From the Gallery at the bottom of the central pane, select the Regions tab.  

ii. Find the Static Content region. Select Static Content and drag it above the 

Customer Report region. 
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g. On the Rendering tab, select the new region. In the Property Editor, in Identification > 

Title enter Quick Filter.  

 

h. In the Quick Filter region, create two filter items: P4_CUSTOMER_ID and P4_CITY to filter 

the report. Create an item for P4_CUSTOMER_ID: 

i. From the Gallery at the bottom of the central pane, select the Items tab. 

ii. Select Select List and drag it to ITEMS in the Quick Filter region. 
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i. On the Rendering tab, select the new item.  

j. In the Property Editor, edit the following: 

 Identification > Name: Enter P4_CUSTOMER_ID. 

 Label > Label: Enter Customer. 
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 List of Values > Type: Select SQL Query. 

 SQL Query: Enter the query, which is provided in 

/home/oracle/labs/labs/lab_12_01_01.txt. 

select cust_first_name||' '||cust_last_name d, customer_id r 

from oehr_customers 

order by 1 

 List of Values > Display Null Value: Select Yes. 

 List of Values > Null Display Value: Enter - Show All –. 

 

k. Create an item for P4_CITY: 

i. From the Gallery at the bottom of the central pane, select the Items tab. 

ii. Select Select List and drag it to the Quick Filter region below the 

P4_CUSTOMER_ID item. 
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l. On the Rendering tab, select the new item.  

m. In the Property Editor, edit the following: 

 Identification > Name: Enter P4_CITY. 

 Label > Label: City (populated by default). 

 Layout > Start New Row: Select No (if not selected by default). 

 Layout > New Column: Select Yes. 

 

 

 List of Values > Type: Select SQL Query. 

 List of Values > SQL Query: Enter the query that is provided in 

/home/oracle/labs/labs/lab_12_01_02.txt. 

select distinct city d, city r 

from oehr_customers 

order by 1 
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 List of Values > Display Null Value: Select Yes (if not selected by default). 

 Null Display Value: Enter - Show All –. 

 

 Click Save. 

n. In the left pane, click the Dynamic Actions tab. 

 

O
ra

cl
e 

In
te

rn
al

 &
 O

ra
cl

e 
Ac

ad
em

y 
U

se
 O

nl
y



 

Copyright © 2019, Oracle and/or its affiliates. All rights reserved. 

406  Practices for Lesson 12: Using Dynamic Actions and Plug-Ins 

o. Right-click Events and select Create Dynamic Action. 

 

p. On the Dynamic Actions tab, select the new dynamic action. 
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q. In the Property Editor, edit the following: 

 Identification > Name: Enter Quick Filter Refresh. 

 When > Event: Select Change. 

 When > Selection Type: Select Item(s). 

 When > Item(s): Select P4_CUSTOMER_ID, P4_CITY. 
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r. On the Dynamic Actions tab, select Quick Filter Refresh > True > Show. 

  

s. In the Property Editor, enter the following: 

 Identification > Action: Select Refresh. 

 Affected Elements > Selection Type: Select Region. 

 Affected Elements > Region: Select Customer Report 

 Execution Options > Fire on Initialization: Select No (if not selected by default). 
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t. On the Rendering tab, under Regions > Content Body, collapse Quick Filter. Select 

Customer Report. 

 

u. On the Property Editor tab, edit the following: 

 Source > Type: Select SQL Query 

 Source > SQL Query: Click the Code Editor icon. 
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 In the Code Editor, add the following WHERE clause (located in the 

/home/oracle/labs/labs/lab_12_01_03.txt file) to the end of the SELECT 

statement and click OK. 

where customer_id = nvl(:P4_CUSTOMER_ID, CUSTOMER_ID) 

and city = nvl(:P4_CITY, CITY) 
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 In Source > Page Items to Submit, select P4_CUSTOMER_ID, P4_CITY. 
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 From Layout > Start New Row, select Yes. 

  

v. Click the Save and Run Page. 

  

w. If you are prompted to sign in, enter your workspace credentials and click Sign In. 

x. The Customers report appears. Review the revised report. 

i. Note that when both the Customer and City filters are set to - Show All - all the 

records display. 
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ii. From the Customer filter, select a customer from the list. What do you observe? 

 

  

O
ra

cl
e 

In
te

rn
al

 &
 O

ra
cl

e 
Ac

ad
em

y 
U

se
 O

nl
y



 

Copyright © 2019, Oracle and/or its affiliates. All rights reserved. 

Practices for Lesson 12: Using Dynamic Actions and Plug-Ins  415 

The revised report appears, displaying the customer. 

 

iii. From the Customer filter, select -Show All-. From the City filter, select Albany. 
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The revised report appears, displaying the customers in the selected city. 

 

iv. Click the Application 111 link on the Runtime Developer toolbar. 
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Solution 12-2: Importing and Using Plug-Ins on Your Page 

Overview 

In this solution, you import and use an item type plug-in and a dynamic action plug-in.  

Note: The solution script generated at the end of this practice does not contain the Rating column. 

Steps 

1. Add a rating column to the CUSTOMERS table. 

a. On the Workspace home page, select the SQL Workshop menu and then select Object 
Browser. 

 

b. In Object Browser: 

i. For Schema at the top right of the window, select OEHR. 

ii. In the Object Selection pane (left pane), select OEHR_CUSTOMERS. 

O
ra

cl
e 

In
te

rn
al

 &
 O

ra
cl

e 
Ac

ad
em

y 
U

se
 O

nl
y



 

Copyright © 2019, Oracle and/or its affiliates. All rights reserved. 

418  Practices for Lesson 12: Using Dynamic Actions and Plug-Ins 

 

O
ra

cl
e 

In
te

rn
al

 &
 O

ra
cl

e 
Ac

ad
em

y 
U

se
 O

nl
y



 

Copyright © 2019, Oracle and/or its affiliates. All rights reserved. 

Practices for Lesson 12: Using Dynamic Actions and Plug-Ins  419 

c. In the Detail pane (right pane), click the Add Column button. 

 

d. On Add Column: 

 Add Column: Enter RATING. 

 Type: Select Number. 

 Precision: Enter 2. 

  

 Click Next >. 
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 Click Finish. The column is added. 

 

e. Click the App Builder menu and select Database Applications. 

 

 

2. Import the Modern Star Rating Item plug-in. 

a. On the App Builder Home page, select the GlobalMart Management Tool application. 

 

b. Click Shared Components.  
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c. Under Other Components, select Plug-Ins. 

 

d. On the Plug-ins page, click Import >. 

 

e. On the Import page, click Browse and select 

/home/oracle/labs/labs/item_type_plugin_com_oracle_apex_starrating_

modern.sql.On the Import page, click Next >. 
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f. After the file is imported, the File Import Confirmation dialog box appears. Click Next > to 

install it. 
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g. The Install Plug-in window appears. For Install Into Application, verify that the GlobalMart 

Management Tool application is selected and click Install Plug-in.  

Note that if the plug-in already exists, it will be replaced. 

 

h. The plug-in is installed. Accept the default Component Settings and click Apply Changes.  

O
ra

cl
e 

In
te

rn
al

 &
 O

ra
cl

e 
Ac

ad
em

y 
U

se
 O

nl
y



 

Copyright © 2019, Oracle and/or its affiliates. All rights reserved. 

424  Practices for Lesson 12: Using Dynamic Actions and Plug-Ins 
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3. Add the Modern Star Rating plug-in to your Customer Details page. 

a. Click Application 111 breadcrumb to return to your application. 

 

b. On the Application home page, select the 9 - Customer Details page.  

  

c. Page Designer appears, displaying Page 9: Customer Details. 

d. In the Gallery at the bottom of the central pane, select the Items tab and find the Star 

Rating [Plug-In]. Select the Modern Star Rating [Plug-In] and then drag and drop it to 

after P9_COUNTRY_ID in the Layout pane. 
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e. On the Rendering tab, verify the newly added plug-in is selected.  

f. In the Property Editor, edit the following: 

 Identification > Name: Enter P9_RATING. 

 Settings > Number of Stars: Enter 5. 

   

 Appearance > Template: Select Optional - Above. 

 

 Source > Type: Select Database Column.  

 For Source > Database Column: Enter RATING.  
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g. Click the Save and Run Page. 
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h. If you are prompted to sign in, enter your workspace credentials and click Sign In. 
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i. Notice that a Rating item now appears at the bottom of the page. Click Rating. 
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j. Click each rating and note the Tooltips that are displayed. 

 

k. Click the Application 111 link on the Runtime Developer toolbar. 
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